aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:32 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:51 +0000
commit4705ee467d8974fcf71e46b52722e90a39cb91e6 (patch)
treee504e7e31410ba2d68b62717b84163a27feb4215 /gnu/packages/python-web.scm
parentb0834fe777541f75d96782bd897b77919cc1c21a (diff)
downloadguix-4705ee467d8974fcf71e46b52722e90a39cb91e6.tar.gz
guix-4705ee467d8974fcf71e46b52722e90a39cb91e6.zip
gnu: python-tinycss: Move to pyproject-build-system.
* gnu/packages/python-web.scm (python-tinycss): [build-system]: Move to pyproject-build-system. [arguments]<#:test-flags>: Ignore failing test. Change-Id: I972a3c6390df5f8af79c952292db8a4e24a4aa33 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index de81c9d474..91daccfd78 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6223,20 +6223,10 @@ the non-map-specific features. It can be used to generate HTML + JS.")
(uri (pypi-uri "tinycss" version))
(sha256
(base32 "0vkifr595h28ymkjhrswwf0bm23lhznh5f44xyp7x7jy1ssnyc0j"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-flake8-isort
- ;; Flake8 and isort tests fail.
- (lambda _
- (substitute* "setup.cfg" ((" --flake8 --isort") ""))
- #t))
- (replace 'check
- (lambda _
- ;; Disable failing test.
- (invoke "python" "-m" "pytest" "-k"
- "not test_speedups"))))))
+ (list #:test-flags
+ '(list "-k" "not test_speedups")))
(native-inputs
(list python-pytest-cov python-pytest-flake8 python-pytest-isort
python-pytest-runner))