aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-16 23:20:34 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:24 +0000
commit3d9c6af89a8828f10645de47178a8563d3115f74 (patch)
tree96d88dfc9c3d44f8baecb2567503be3075638e3f /gnu/packages/python-web.scm
parent978334062ca41025609d4bcf81b06e22906fcb77 (diff)
downloadguix-3d9c6af89a8828f10645de47178a8563d3115f74.tar.gz
guix-3d9c6af89a8828f10645de47178a8563d3115f74.zip
gnu: python-werkzeug: Update to 3.1.3.
* gnu/packages/python-web.scm (python-werkzeug): Update to 3.1.3. [build-system]: Swap to pyproject-build-system. [arguments]<phases>: Use default 'check phase. [propagated-inputs]: Add python-markupsafe. [native-inputs]: Add python-flit-core, python-watchdog, and python-ephemeral-port-reserve. Change-Id: I97a971034993272b369803eb24f7c6f718da55af
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm36
1 files changed, 20 insertions, 16 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b72f88a68d..5a210a0fa7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5593,29 +5593,33 @@ List. Forked from and using the same API as the publicsuffix package.")
(define-public python-werkzeug
(package
(name "python-werkzeug")
- (version "2.0.2")
+ (version "3.1.3")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "Werkzeug" version))
+ (uri (pypi-uri "werkzeug" version))
(sha256
(base32
- "16nvv9dh37ssf5pkny9yj2li0n6wyzsygh8a9i86r3gfipybcaxa"))))
- (build-system python-build-system)
+ "0ij7si3aa3ykac7k7fz481h4majqqwn2iqwhjxkji4y18plkqwk0"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "-m" "pytest"
- ;; Test tries to use the network.
- "-k not test_reloader_sys_path")))))))
- (propagated-inputs
- (list python-requests))
+ (list
+ #:test-flags
+ ;; Test requiring networking setup.
+ #~(list "--ignore=tests/test_serving.py"
+ "--deselect=tests/test_debug.py::test_basic"
+ "--deselect=tests/test_exceptions.py::test_response_body"
+ "--deselect=tests/middleware/test_http_proxy.py::test_http_proxy")))
(native-inputs
- (list python-pytest python-pytest-timeout python-pytest-xprocess))
+ (list python-flit-core
+ python-pytest
+ python-watchdog
+ python-ephemeral-port-reserve
+ python-pytest-timeout
+ python-pytest-xprocess))
+ (propagated-inputs
+ (list python-markupsafe
+ python-requests))
(home-page "https://palletsprojects.com/p/werkzeug/")
(synopsis "Utilities for WSGI applications")
(description "One of the most advanced WSGI utility modules. It includes a