aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-23 19:53:55 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:58 +0000
commit3c2943b621c05899aa59f0932b8e1d1053869db1 (patch)
tree22f9feccdedc63c07f972f2de6be05c88f7d2cde /gnu/packages/python-web.scm
parent5f49430d303a88407c71506f5a7dac8eb8f877cf (diff)
downloadguix-3c2943b621c05899aa59f0932b8e1d1053869db1.tar.gz
guix-3c2943b621c05899aa59f0932b8e1d1053869db1.zip
gnu: build-system/pyproject: Add missing native-inputs.
* gnu/packages/bioinformatics.scm (python-ega-download-client) [native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/databases.scm (datasette)[native-inputs]: Add python-pip. * gnu/packages/django.scm (python-django-localflavor, python-django-contact-form)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/graphviz.scm (python-uqbar)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/jupyter.scm (python-jupyterlab-server)[native-inputs]: Add python-wheel. (python-nbstripout)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/machine-learning.scm (python-captum, python-linear-operator, python-gpytorch)[native-inputs]: Add python-setuptools. * gnu/packages/music.scm (abjad, abjad-ext-rmarkers, abjed-ext-nauert, python-mutagen)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/package-management.scm (python-conda-package-handling)[native-inputs]: Add python-setuptools and python-wheel. (conda)[native-inputs]: Add python-wheel. * gnu/packages/python-check.scm (python-pyinstrument, python-pytest-testmon, python-pytest-trio, python-nbval, python-pytest-toolbox)[native-inputs]: Add python-setuptools and python-wheel. (python-nptyping)[native-inputs]: Add python-setuptools. * gnu/packages/python-check.scm (python-dask-expr)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/python-web.scm (parfive, python-aioftp, python-hupper, python-sanic, python-mechanicalsoup, python-tinycss, python-aiostream, python-cbor2, gunicorn)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/python-xyz.scm (python-apprise, python-jaraco-classes, python-sparse, python-shtab, python-pyan3)[native-inputs]: Add python-setuptools. (python-jupytext, python-orderedmultidict, python-identify, python-nodeenv, python-cfgv, python-zarr, python-multipart, python-nbconvert, python-cram, python-immutables, python-numpydoc, python-cairosvg, python-unidecode, python-black, python-multidict, python-mpv-jsonipc, python-humanize, python-cmd2)[native-inputs]: Add python-setuptools and python-wheel. (python-partd, python-dask, python-zarr)[native-inputs]: Add python-wheel. (python-nbconvert)[propagated-inputs]: Add texlive-etoolbox. Remove duplicate textlive-jknapltx. (python-isort)[native-inputs]: Add python-pip. * gnu/packages/simulation.scm (python-fenics-dijitso)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/sphinx.scm (python-pydata-sphinx-theme, python-sphinx-autodoc-typehints)[native-inputs]: Add python-setuptools. * gnu/packages/syndication.scm (tuir)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/terminals.scm (python-halo)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/time.scm (python-arrow, python-dateutil) [native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/version-control.scm (pre-commit)[native-inputs]: Add python-setuptools and python-wheel. Remove input labels. * gnu/packages/virtualization.scm (python-qemu-qmp, python-transient)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/xorg.scm (python-xcffib)[native-inputs]: Add python-setuptools and python-wheel. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Change-Id: Id61cf8cdc47bd4c2871c0a9c8e9a5bfd51157df0
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm52
1 files changed, 40 insertions, 12 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5367d132b0..47d5011487 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -706,7 +706,9 @@ comes with a SOCKS proxy client.")
(list python-pytest
python-pytest-asyncio
python-pytest-cov
- python-pytest-runner))
+ python-pytest-runner
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/vxgmichel/aiostream")
(synopsis "Generator-based operators for asynchronous iteration")
(description "@code{aiostream} provides a collection of stream operators that can
@@ -1038,7 +1040,12 @@ to the OVHcloud APIs.")
(sha256
(base32 "15y78xcc3zkmvj1mdzz8gyhf3apbl91073kwhzbjk5abc1civwlw"))))
(build-system pyproject-build-system)
- (native-inputs (list python-pytest python-pytest-cov python-setuptools-scm))
+ (native-inputs
+ (list python-pytest
+ python-pytest-cov
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(home-page "https://github.com/agronholm/cbor2")
(synopsis "Concise Binary Object Representation (CBOR) (de)serializer")
(description "This Python library provides encoding and decoding for the
@@ -1447,7 +1454,9 @@ HTTP servers, RESTful APIs, and web services.")
python-pytest-cov
python-pytest-localserver
python-pytest-socket
- python-setuptools-scm))
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(home-page "https://parfive.readthedocs.io/")
(synopsis "HTTP and FTP parallel file downloader")
(description
@@ -1634,7 +1643,9 @@ object graph to and from JSON.")
python-pytest-httpbin
python-pytest-mock
python-pytest-runner
- python-requests-mock))
+ python-requests-mock
+ python-setuptools
+ python-wheel))
(home-page "https://mechanicalsoup.readthedocs.io/")
(synopsis "Python library for automating website interaction")
(description
@@ -3924,9 +3935,14 @@ adapter for use with the Requests library.")
(base32
"0w621mg956m9rn7v39jpwi4gpnpl90pprwl29cp640dahqqv38ms"))))
(build-system pyproject-build-system)
- (native-inputs (list python-async-timeout python-pytest
- python-pytest-asyncio python-pytest-cov
- python-trustme))
+ (native-inputs
+ (list python-async-timeout
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-cov
+ python-setuptools
+ python-trustme
+ python-wheel))
(propagated-inputs (list python-siosocks))
(home-page "https://aioftp.readthedocs.io/")
(synopsis "FTP client/server for asyncio in Python")
@@ -6222,8 +6238,12 @@ the non-map-specific features. It can be used to generate HTML + JS.")
(list #:test-flags
'(list "-k" "not test_speedups")))
(native-inputs
- (list python-pytest-cov python-pytest-flake8 python-pytest-isort
- python-pytest-runner))
+ (list python-pytest-cov
+ python-pytest-flake8
+ python-pytest-isort
+ python-pytest-runner
+ python-setuptools
+ python-wheel))
(home-page "https://tinycss.readthedocs.io/")
(synopsis "Complete yet simple CSS parser for Python")
(description
@@ -6443,6 +6463,7 @@ event loop. It is implemented in Cython and uses libuv under the hood.")
python-pytest-cov
python-sphinx
texinfo))
+ (propagated-inputs (list python-packaging python-setuptools python-wheel))
(home-page "https://gunicorn.org/")
(synopsis "Python WSGI HTTP Server for UNIX")
(description "Gunicorn ‘Green Unicorn’ is a Python WSGI HTTP
@@ -7254,8 +7275,13 @@ according to the standard set by PasteDeploy")
(build-system python-build-system)
(arguments '(#:test-target "pytest"))
(native-inputs
- (list python-pytest python-pytest-runner python-watchdog python-mock
- python-pytest-cov))
+ (list python-mock
+ python-pytest
+ python-pytest-cov
+ python-pytest-runner
+ python-setuptools
+ python-watchdog
+ python-wheel))
(propagated-inputs
(list python-pytz))
(home-page "https://readthedocs.org/projects/hupper")
@@ -8046,11 +8072,13 @@ applications.")
python-pytest-benchmark
python-pytest-sanic
python-sanic-testing
+ python-setuptools
python-slotscheck
python-towncrier
python-tox
python-types-ujson
- python-uvicorn))
+ python-uvicorn
+ python-wheel))
(home-page "https://github.com/sanic-org/sanic/")
(synopsis "Async Python web server/framework")
(description