aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-09-07 18:56:54 +0200
committerjgart <jgart@dismail.de>2024-09-09 23:56:09 -0500
commit357effe1ee0df5125f96ff2dbeec581afd707da4 (patch)
treea0d1ee70902987e003b363b63cbe44a93f685c31 /gnu/packages/python-web.scm
parent09d2f62c0f5dc94316b9d959ff588fb0dc8e264d (diff)
downloadguix-357effe1ee0df5125f96ff2dbeec581afd707da4.tar.gz
guix-357effe1ee0df5125f96ff2dbeec581afd707da4.zip
gnu: python-huggingface-hub: Update to 0.23.2.
* gnu/packages/python-web.scm (python-huggingface-hub): Update to 0.23.2. Change-Id: I06989e883f54d9f0fc8db002d0a580008f6c6b67 Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index bb1b912c0c..2a7dc8f8b3 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -143,7 +143,7 @@
(define-public python-huggingface-hub
(package
(name "python-huggingface-hub")
- (version "0.20.3")
+ (version "0.23.2")
(source
(origin
(method git-fetch)
@@ -152,7 +152,7 @@
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "00indl9labvqvm4m0y5jbzl68cgj8i60a6qy498gpnjj2pqk4l6v"))))
+ (base32 "0hygxqcixkc1d9sr47j2km6z0p17aj4k1dzm4cvpddrvhrgqayq5"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -185,7 +185,11 @@
"--ignore=tests/test_utils_git_credentials.py"
"--ignore=tests/test_utils_http.py"
"--ignore=tests/test_utils_pagination.py"
- "--ignore=tests/test_webhooks_server.py")
+ "--ignore=tests/test_webhooks_server.py"
+ "-k" (string-append
+ "not test_push_to_hub"
+ " and not test_from_pretrained_model_id_only"
+ " and not test_from_pretrained_model_id_and_revision"))
#:phases
'(modify-phases %standard-phases
(add-before 'check 'pre-check