aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2022-10-31 17:08:32 -0700
committerVagrant Cascadian <vagrant@debian.org>2022-10-31 18:13:48 -0700
commit15ff5eebb6109159a9ea4afd8cc942d9e0113148 (patch)
tree3723a7505660dc44733f8cf8b52de7426a62cb5b /gnu/packages/python-web.scm
parent41a5720be9f0dd105e53ac73253445b966288ac7 (diff)
downloadguix-15ff5eebb6109159a9ea4afd8cc942d9e0113148.tar.gz
guix-15ff5eebb6109159a9ea4afd8cc942d9e0113148.zip
gnu: Fix various lint issues in synopsis and descriptions.
* gnu/packages/android.scm (etc1tool)[synopsis]: Drop trailing period. * gnu/packages/bioinformatics.scm (mudskipper)[synopsis]: Likewise. * gnu/packages/crates-io.scm (rust-async-log-attributes-1)[synopsis]: Likewise. (rust-atomic-polyfill-1)[synopsis]: Likewise. (rust-modifier-0.1)[synopsis]: Likewise. (rust-openssl-macros-0.1)[synopsis]: Likewise. (rust-syn-mid-0.5)[synopsis]: Likewise. (rust-toml-edit-0.14)[synopsis]: Likewise. (rust-valuable-derive-0.1)[synopsis]: Likewise. (rust-inflections-1)[synopsis]: Likewise. * gnu/packages/databases.scm (python-databases)[synopsis]: Likewise. * gnu/packages/games.scm (liquidwar6)[synopsis]: Likewise. * gnu/packages/golang.scm (go-golang.org-x-sync-errgroup)[synopsis]: Likewise. * gnu/packages/guile-xyz.scm (guile-config)[synopsis]: Likewise. * gnu/packages/haskell-web.scm (ghc-hxt-xpath)[synopsis]: Likewise. * gnu/packages/haskell-xyz.scm (ghc-string-qq)[synopsis]: Likewise. * gnu/packages/machine-learning.scm (python-lap)[synopsis]: Likewise. (python-pyro-api)[synopsis]: Likewise. * gnu/packages/messaging.scm (python-librecaptcha)[synopsis]: Likewise. * gnu/packages/python-check.scm (python-pytest-cram)[synopsis]: Likewise. * gnu/packages/python-web.scm (python-jschema-to-python)[synopsis]: Likewise. (python-sarif-om)[synopsis]: Likewise. (python-socksio)[synopsis]: Likewise. (python-msrest)[synopsis]: Likewise. * gnu/packages/tor.scm (torsocks)[synopsis]: Likewise. * gnu/packages/cran.scm (r-rlist)[synopsis]: Remove leading article. * gnu/packages/crates-io.scm (rust-clippy-lints-0.0.153)[synopsis]: Likewise. (rust-simplelog-0.11)[synopsis]: Likewise. * gnu/packages/samba.scm (wsdd)[synopsis]: Likewise. * gnu/packages/crates-io.scm (rust-spki-0.4)[synopsis]: Remove trailing whitespace. * gnu/packages/golang.scm (go-github-com-mattn-go-zglob)[description]: Remove leading whitespace. * gnu/packages/haskell-check.scm (ghc-crypto-cipher-tests)[description]: Likewise. * gnu/packages/lisp-xyz.scm (sbcl-ctype)[synopsis]: Remove trailing whitespace. * gnu/packages/mpi.scm (openmpi-thread-multiple)[description]: Remove leading whitespace. * gnu/packages/node-xyz.scm (node-string-decoder)[synopsis]: Remove trailing whitespace.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 59d677ca35..00ce3c63ff 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -782,7 +782,7 @@ for resource properties and best practices.")
(propagated-inputs (list python-attrs python-jsonpickle python-pbr))
(native-inputs (list python-pytest))
(home-page "https://github.com/microsoft/jschema-to-python")
- (synopsis "Generate Python classes from a JSON schema.")
+ (synopsis "Generate Python classes from a JSON schema")
(description "This package generates source code for Python classes from a
@url{http://jschema.org,JSchema} JSON schema.")
(license license:expat)))
@@ -801,7 +801,7 @@ for resource properties and best practices.")
(propagated-inputs (list python-attrs))
(native-inputs (list python-pbr))
(home-page "https://github.com/microsoft/sarif-python-om")
- (synopsis "Python implementation of the SARIF 2.1.0 object model.")
+ (synopsis "Python implementation of the SARIF 2.1.0 object model")
(description "This module contains classes for the object model defined
by the @url{https://sarifweb.azurewebsites.net,Static Analysis Results
Interchange Format (SARIF)} file format.")
@@ -6645,7 +6645,7 @@ your code non-blocking and speedy.")
(base32 "1b64j45w35jzhjhnq44bnyad9ydh1iyyd7a6j2c8phxmllyyp2zq"))))
(build-system python-build-system)
(home-page "https://github.com/sethmlarson/socksio")
- (synopsis "Sans-I/O implementation of SOCKS4, SOCKS4A, and SOCKS5.")
+ (synopsis "Sans-I/O implementation of SOCKS4, SOCKS4A, and SOCKS5")
(description "The @code{socksio} Python module is a client-side sans-I/O
SOCKS proxy implementation. It supports SOCKS4, SOCKS4A, and SOCKS5.
@code{socksio} is a sans-I/O library similar to @code{h11} or @code{h2}; this
@@ -6696,7 +6696,7 @@ SOCKS protocols. It can be paired with any I/O library.")
python-pytest-asyncio
python-pytest-trio))
(home-page "https://github.com/Azure/msrest-for-python")
- (synopsis "AutoRest swagger generator Python client runtime.")
+ (synopsis "AutoRest swagger generator Python client runtime")
(description "This package provides the runtime library @code{msrest} for
AutoRest-generated Python clients.")
(license license:expat)))