aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-05 16:00:09 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:02 +0000
commit149837f060b0ffcffe03a8e90fa0099f54ec5221 (patch)
tree61ee2418c110cb68603b1b8cf5f6dd3dc0013418 /gnu/packages/python-web.scm
parentc7f304253f1b0d3a842b6c59201baca7724e1c21 (diff)
downloadguix-149837f060b0ffcffe03a8e90fa0099f54ec5221.tar.gz
guix-149837f060b0ffcffe03a8e90fa0099f54ec5221.zip
gnu: python-responses: Update to 0.25.3.
* gnu/packages/python-web.scm (python-responses): Update to 0.25.3. [build-system]: Swap to pyproject-build-system. [arguments]<phases>: Use default check phase. [propagated-inputs]: Remove python-toml, python-types-toml, and python-typing-extensions; add python-pyyaml. [native-inputs]: Add python-setuptools, python-tomli, python-tomli-w, and python-wheel. Change-Id: Ib874a6634d496083c97a933c3402f2383e707bd7
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm23
1 files changed, 9 insertions, 14 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d1e64648cd..b150124128 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4659,30 +4659,25 @@ Python.")
(define-public python-responses
(package
(name "python-responses")
- (version "0.22.0")
+ (version "0.25.3")
(source (origin
(method url-fetch)
(uri (pypi-uri "responses" version))
(sha256
(base32
- "0bhhffwl0zqin4xc89nc97ynzr7l3j4b8rjqk9w9flnj2cmcnsir"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-v")))))))
+ "1fld6lsa143md4lxccwxq9iyqm9d8a05i9sp7lqjibnrmd3r4yv1"))))
+ (build-system pyproject-build-system)
(native-inputs
(list python-pytest
python-pytest-asyncio
- python-pytest-httpserver))
+ python-pytest-httpserver
+ python-setuptools
+ python-tomli
+ python-tomli-w
+ python-wheel))
(propagated-inputs
(list python-requests
- python-toml
- python-types-toml
- python-typing-extensions
+ python-pyyaml
python-urllib3))
(home-page "https://github.com/getsentry/responses")
(synopsis "Utility for mocking out the `requests` Python library")