aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 20:15:27 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-30 10:30:48 +0100
commitc6ecd58a0d3b8c5f77de3583e4c1a9484c19f0d5 (patch)
tree119b8bd33acddda2bf1ce644a10a1ba2bdd8feb5 /gnu/packages/python-science.scm
parent71c5db87694812add83633f8ac9332fd9b3fe59b (diff)
downloadguix-c6ecd58a0d3b8c5f77de3583e4c1a9484c19f0d5.tar.gz
guix-c6ecd58a0d3b8c5f77de3583e4c1a9484c19f0d5.zip
gnu: Add python-mpl-scatter-density.
* gnu/packages/python-science.scm (python-mpl-scatter-density): New variable. Change-Id: Id4ea80b2c62642affbe1944e0c5126a1c53d16c3
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 7012a942d3..4bb8ac342d 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -779,6 +779,37 @@ volume computations for simple domains like regular polygons, disks,
spheres, cubes, etc.")
(license license:gpl3+)))
+(define-public python-mpl-scatter-density
+ (package
+ (name "python-mpl-scatter-density")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mpl-scatter-density" version))
+ (sha256
+ (base32 "083n4xkwjmxvij9i1xhfnxz8vk39ay0baam4nf0khvcihw47bkna"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; See <https://github.com/astrofrog/mpl-scatter-density/issues/42>.
+ #:test-flags #~(list "-k" "not test_default_dpi")))
+ (propagated-inputs
+ (list python-fast-histogram
+ python-matplotlib
+ python-numpy))
+ (native-inputs
+ (list python-pytest
+ python-pytest-cov
+ python-pytest-mpl
+ python-setuptools-scm))
+ (home-page "https://github.com/astrofrog/mpl-scatter-density")
+ (synopsis "Matplotlib helpers to make density scatter plots")
+ (description
+ "This package provides functionality to make it easy to make scatter
+density maps, both for interactive and non-interactive use.")
+ (license license:bsd-2)))
+
(define-public python-pyamg
(package
(name "python-pyamg")