aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 20:15:36 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-30 10:30:47 +0100
commit77d4efec425418d7cb11369cb8b1d59b8b4dfd2b (patch)
tree03c8231d852be47312f7d55faf8ff5be9618b273 /gnu/packages/python-science.scm
parent31e3303dd7a063c8c3a33c1d91499f54e6539243 (diff)
downloadguix-77d4efec425418d7cb11369cb8b1d59b8b4dfd2b.tar.gz
guix-77d4efec425418d7cb11369cb8b1d59b8b4dfd2b.zip
gnu: python-fast-histogram: Adjust inputs.
* gnu/packages/python-science.scm (python-fast-histogram): Fix lint warnings and adjust inputs. [native-inputs]: Add python-setuptools-scm. Change-Id: Ic51660d7542114f2bb45be4720ab4d899633e56d
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 8ba3432637..7012a942d3 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1551,17 +1551,20 @@ higher scores.")
(lambda _
(invoke "python" "setup.py" "build_ext" "--inplace"))))))
(propagated-inputs (list python-numpy))
- (native-inputs (list python-hypothesis python-pytest))
+ (native-inputs
+ (list python-hypothesis
+ python-pytest
+ python-setuptools-scm))
(home-page "https://github.com/astrofrog/fast-histogram")
(synopsis "Fast simple 1D and 2D histograms")
(description
"The fast-histogram mini-package aims to provide simple and fast
-histogram functions for regular bins that don't compromise on performance. It
+histogram functions for regular bins that don't compromise on performance. It
doesn't do anything complicated - it just implements a simple histogram
-algorithm in C and keeps it simple. The aim is to have functions that are fast
-but also robust and reliable. The result is a 1D histogram function here that
-is 7-15x faster than @code{numpy.histogram}, and a 2D histogram function that
-is 20-25x faster than @code{numpy.histogram2d}.")
+algorithm in C and keeps it simple. The aim is to have functions that are
+fast but also robust and reliable. The result is a 1D histogram function here
+that is 7-15x faster than @code{numpy.histogram}, and a 2D histogram function
+that is 20-25x faster than @code{numpy.histogram2d}.")
(license license:bsd-3)))
(define-public python-fastcluster