aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-12-15 22:31:55 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-12-16 23:32:51 +0300
commit6d6a1e37b155c1e039c79a18a5ef665b59ffa20a (patch)
tree253e64fb83d849da29e0fbda6e00bda567a8d12d /gnu/packages/python-crypto.scm
parentbfe91a82e4a4e2e1649816f780654ecdd0aa9ab7 (diff)
downloadguix-6d6a1e37b155c1e039c79a18a5ef665b59ffa20a.tar.gz
guix-6d6a1e37b155c1e039c79a18a5ef665b59ffa20a.zip
gnu: python-spake2: Update to 0.9.
* gnu/packages/python-crypto.scm (python-spake2): Update to 0.9. [propagated-inputs]: Add python-cryptography. Change-Id: I9122e657446cb92a7fd1325cdbed63f6ab73428f Reviewed-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index bf2a532cf4..3cd58bf0ea 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1329,17 +1329,17 @@ Derivation function (HKDF) defined in RFC 5869.")
(define-public python-spake2
(package
(name "python-spake2")
- (version "0.8")
+ (version "0.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "spake2" version))
(sha256
(base32
- "1x16r7lrbklvfzbacb66qv9iiih6liq1y612dqh2chgf555n2yn1"))))
+ "0d4kbaxi4cv8klyqh6yb0p0qiwfdwvczy1h2mzvmlfdcsnlc87s2"))))
(build-system python-build-system)
(propagated-inputs
- (list python-hkdf))
+ (list python-cryptography python-hkdf))
(home-page "https://github.com/warner/python-spake2")
(synopsis "SPAKE2 password-authenticated key exchange in Python")
(description "This package provides a Python implementation of the SPAKE2