aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-22 13:34:05 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:28 +0000
commit7427ff48be0db84a5dfb2283668f08cfdeb5cd4e (patch)
treeca73586a8ad8d408493838ad46f6abd5bc2f5db2 /gnu/packages/python-check.scm
parent27fdf6fa94872a4fec99809cacb6afbc1a7077ec (diff)
downloadguix-7427ff48be0db84a5dfb2283668f08cfdeb5cd4e.tar.gz
guix-7427ff48be0db84a5dfb2283668f08cfdeb5cd4e.zip
gnu: python-pytest-metadata: Update to 3.1.1.
* gnu/packages/python-check.scm (python-pytest-metadata): Update to 3.1.1. [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-hatchling and python-hatch-vcs. Change-Id: If6d335a10a8eafcbab09e6149f8117647f95990f
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index a29352b531..1b80e402fd 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -953,22 +953,19 @@ someone to import them in their actual tests to use them.")
(define-public python-pytest-metadata
(package
(name "python-pytest-metadata")
- (version "1.11.0")
+ (version "3.1.1")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "pytest-metadata" version))
+ (uri (pypi-uri "pytest_metadata" version))
(sha256
- (base32 "1wgcz0w053lnjln0081kjmfflaq7bwncxdzx7k63kr9lkpa0ddbi"))))
- (build-system python-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv")))))))
- (native-inputs (list python-pytest python-setuptools-scm))
+ (base32 "1j0ph028mj81314vxb027d5b98xii3zl2vd9i8b3zh7val1rp8nj"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-hatchling
+ python-hatch-vcs
+ python-pytest
+ python-setuptools-scm))
(home-page "https://github.com/pytest-dev/pytest-metadata")
(synopsis "Access test session metadata with Pytest")
(description