aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-23 19:53:55 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:58 +0000
commit3c2943b621c05899aa59f0932b8e1d1053869db1 (patch)
tree22f9feccdedc63c07f972f2de6be05c88f7d2cde /gnu/packages/python-check.scm
parent5f49430d303a88407c71506f5a7dac8eb8f877cf (diff)
downloadguix-3c2943b621c05899aa59f0932b8e1d1053869db1.tar.gz
guix-3c2943b621c05899aa59f0932b8e1d1053869db1.zip
gnu: build-system/pyproject: Add missing native-inputs.
* gnu/packages/bioinformatics.scm (python-ega-download-client) [native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/databases.scm (datasette)[native-inputs]: Add python-pip. * gnu/packages/django.scm (python-django-localflavor, python-django-contact-form)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/graphviz.scm (python-uqbar)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/jupyter.scm (python-jupyterlab-server)[native-inputs]: Add python-wheel. (python-nbstripout)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/machine-learning.scm (python-captum, python-linear-operator, python-gpytorch)[native-inputs]: Add python-setuptools. * gnu/packages/music.scm (abjad, abjad-ext-rmarkers, abjed-ext-nauert, python-mutagen)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/package-management.scm (python-conda-package-handling)[native-inputs]: Add python-setuptools and python-wheel. (conda)[native-inputs]: Add python-wheel. * gnu/packages/python-check.scm (python-pyinstrument, python-pytest-testmon, python-pytest-trio, python-nbval, python-pytest-toolbox)[native-inputs]: Add python-setuptools and python-wheel. (python-nptyping)[native-inputs]: Add python-setuptools. * gnu/packages/python-check.scm (python-dask-expr)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/python-web.scm (parfive, python-aioftp, python-hupper, python-sanic, python-mechanicalsoup, python-tinycss, python-aiostream, python-cbor2, gunicorn)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/python-xyz.scm (python-apprise, python-jaraco-classes, python-sparse, python-shtab, python-pyan3)[native-inputs]: Add python-setuptools. (python-jupytext, python-orderedmultidict, python-identify, python-nodeenv, python-cfgv, python-zarr, python-multipart, python-nbconvert, python-cram, python-immutables, python-numpydoc, python-cairosvg, python-unidecode, python-black, python-multidict, python-mpv-jsonipc, python-humanize, python-cmd2)[native-inputs]: Add python-setuptools and python-wheel. (python-partd, python-dask, python-zarr)[native-inputs]: Add python-wheel. (python-nbconvert)[propagated-inputs]: Add texlive-etoolbox. Remove duplicate textlive-jknapltx. (python-isort)[native-inputs]: Add python-pip. * gnu/packages/simulation.scm (python-fenics-dijitso)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/sphinx.scm (python-pydata-sphinx-theme, python-sphinx-autodoc-typehints)[native-inputs]: Add python-setuptools. * gnu/packages/syndication.scm (tuir)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/terminals.scm (python-halo)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/time.scm (python-arrow, python-dateutil) [native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/version-control.scm (pre-commit)[native-inputs]: Add python-setuptools and python-wheel. Remove input labels. * gnu/packages/virtualization.scm (python-qemu-qmp, python-transient)[native-inputs]: Add python-setuptools and python-wheel. * gnu/packages/xorg.scm (python-xcffib)[native-inputs]: Add python-setuptools and python-wheel. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Change-Id: Id61cf8cdc47bd4c2871c0a9c8e9a5bfd51157df0
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm27
1 files changed, 22 insertions, 5 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index aa915731fd..353acaac26 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -467,7 +467,9 @@ result documents that can be read by tools such as Jenkins or Bamboo.")
python-greenlet
python-pytest
python-pytest-asyncio
- python-pytest-trio))
+ python-pytest-trio
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/joerick/pyinstrument")
(synopsis "Call stack profiler for Python")
(description
@@ -1299,7 +1301,11 @@ simpler.")
(base32 "01qhbkb3n8c5c4id94w6b06q9wb7b6a33mqwyrkdfzk5pzv1gcyd"))))
(build-system pyproject-build-system)
(arguments (list #:tests? #false)) ;there are none
- (native-inputs (list python-coverage python-pytest))
+ (native-inputs
+ (list python-coverage
+ python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/tarpas/pytest-testmon")
(synopsis "Selects tests affected by changed files and methods")
(description
@@ -1328,7 +1334,11 @@ simpler.")
;; No keyboard interrupt in our build environment.
" and not test_actual_test"))))
(native-inputs
- (list python-hypothesis python-pytest python-pytest-cov))
+ (list python-hypothesis
+ python-pytest
+ python-pytest-cov
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-async-generator python-outcome python-pytest python-trio))
(home-page "https://github.com/python-trio/pytest-trio")
@@ -1617,7 +1627,11 @@ service processes for your tests with pytest.")
(substitute* "setup.cfg"
((".*timeout.*") ""))))))))
(native-inputs
- (list python-pydantic python-pytest python-pytest-isort))
+ (list python-pydantic
+ python-pytest
+ python-pytest-isort
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/samuelcolvin/pytest-toolbox")
(synopsis "Numerous useful plugins for Pytest")
(description
@@ -1708,7 +1722,9 @@ notebooks.")
(native-inputs
(list python-pytest
python-pytest-cov
- python-sympy))
+ python-setuptools
+ python-sympy
+ python-wheel))
(propagated-inputs
(list python-coverage
python-ipykernel
@@ -2229,6 +2245,7 @@ them using any Python VM with basically no runtime overhead.")
(native-inputs
(list python-beartype
python-mypy
+ python-setuptools
python-typeguard
python-wheel))
(propagated-inputs (list python-numpy python-typing-extensions))