aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-build.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-04-28 11:24:26 +0200
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2023-05-05 09:13:57 +0200
commitd1e4803474de384b40064a86b690d276e0e0ba13 (patch)
treec90afb207743970e36a884435ff70ff2eb22d241 /gnu/packages/python-build.scm
parent3c91f4ca490a7ac56dc0aebbca9c4bf4df201877 (diff)
downloadguix-d1e4803474de384b40064a86b690d276e0e0ba13.tar.gz
guix-d1e4803474de384b40064a86b690d276e0e0ba13.zip
gnu: Add python-pdm-backend.
* gnu/packages/python-build.scm (python-pdm-backend): New variable.
Diffstat (limited to 'gnu/packages/python-build.scm')
-rw-r--r--gnu/packages/python-build.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 70719c44d4..154c97e9e4 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -715,3 +715,31 @@ parts of files defined using cut-off points or regular expressions.")
(description "This package is a plugin for Hatch that uses your preferred
version control system (like Git) to determine project versions.")
(license license:expat)))
+
+(define-public python-pdm-backend
+ (package
+ (name "python-pdm-backend")
+ (version "2.0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pdm_backend" version))
+ (sha256
+ (base32
+ "06bq846yy33alxbljgcf4lx9g2mx4b2sv04i59rrn9rxapcg2651"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f ; Depends on pytest, which we cannot import into this module.
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-pythonpath
+ (lambda _
+ (setenv "PYTHONPATH" (string-append (getcwd) "/src")))))))
+ (home-page "https://pdm-backend.fming.dev/")
+ (synopsis
+ "PEP 517 build backend for PDM")
+ (description
+ "PDM-Backend is a build backend that supports the latest packaging
+standards, which includes PEP 517, PEP 621 and PEP 660.")
+ (license license:expat)))
+