path: root/gnu/packages/pumpio.scm
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2020-04-23 15:55:32 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-01 01:21:04 +0200
commit22df0a1f59e97e4ece7219b12dedabfc8a9a983c (patch)
tree9a24ef102f7d2c8b1af45191cd3cd2e3f71b12c7 /gnu/packages/pumpio.scm
parent135c1e0e433edc8258b1a7d018258e3ef5919122 (diff)
downloadguix-22df0a1f59e97e4ece7219b12dedabfc8a9a983c.tar.gz
guix-22df0a1f59e97e4ece7219b12dedabfc8a9a983c.zip
gnu: Add libqb.
* gnu/packages/hardware.scm (libqb): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/pumpio.scm')
0 files changed, 0 insertions, 0 deletions
scm?id=3be81c85cfa9185447bb47d9e35dd7c93f87407b'>gnu/packages/django.scm
@@ -737,26 +737,26 @@ project aims to bulk update given objects using one query over Django ORM.")
(define-public python-django-contact-form
(package
(name "python-django-contact-form")
- (version "1.3")
+ (version "1.8.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "django-contact-form" version))
(sha256
(base32
- "0az590y56k5ahv4sixrkn54d3a8ig2q2z9pl6s3m4f533mx2gj17"))))
+ "1zv7bcjfrg32gcsq3bclkld79l6mcy2wcvlj81h7q2ppv1wm8vqs"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda _
- ;; the next version will need "make test"
- (invoke "flake8" "contact_form")
- (invoke "coverage" "run" "contact_form/runtests.py")
- (invoke "coverage" "report" "-m" "--fail-under" "0"))))))
+ (setenv "PYTHONPATH"
+ (string-append "./build/lib:"
+ (getenv "PYTHONPATH")))
+ (invoke "coverage" "run" "--source" "contact_form"
+ "runtests.py"))))))
(native-inputs
- `(("python-coverage" ,python-coverage)
- ("python-flake8" ,python-flake8)))
+ `(("python-coverage" ,python-coverage)))
(propagated-inputs
`(("python-django" ,python-django)))
(home-page "https://github.com/ubernostrum/django-contact-form")