;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2018 Gábor Boskovits ;;; Copyright © 2018, 2019 Oleg Pykhalov ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu tests monitoring) #:use-module (gnu packages databases) #:use-module (gnu packages monitoring) #:use-module (gnu packages php) #:use-module (gnu services) #:use-module (gnu services monitoring)
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-11 08:33:02 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:41 +0000
commitfdc0fefd46a45b70784a4e3f8900cbe593426a9e (patch)
tree13c3736334bde1c3ec75d67f4e430396e23eed3f /gnu/packages/protobuf.scm
parentca945f7c35bbc5d05a6ad7e5baa15f79e0fd0ecc (diff)
downloadguix-fdc0fefd46a45b70784a4e3f8900cbe593426a9e.tar.gz
guix-fdc0fefd46a45b70784a4e3f8900cbe593426a9e.zip
build-system/pyproject: Use python-sans-pip-wrapper as default-python.
Also adds python-setuptools and python-wheel to relevant packages, either to native-inputs or to propagated inputs if the pkg_resources Python module is loaded at runtime. * guix/build-system/pyproject.scm (default-python): Default to python-sans-pip-wrapper. Change-Id: I2d986c2225114f54459dd6bb360913106e52cdf4
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 59f49c8cf4..11e81527e0 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -395,7 +395,9 @@ any memory-restricted system.")
(list python-grpc-stubs
python-grpcio-tools
python-pytest
- python-typing-extensions))
+ python-typing-extensions
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list protobuf
python-protobuf
.pid") marionette)) ;; Wait for zabbix-agent to be up and running. (test-assert "zabbix-agent running" (marionette-eval '(begin (use-modules (gnu services herd)) (start-service 'zabbix-agent)) marionette)) ;; Make sure the PID file is created. (test-assert "zabbix-agent PID file" (marionette-eval '(file-exists? "/var/run/zabbix/zabbix_agent.pid") marionette)) ;; Wait for php-fpm to be up and running. (test-assert "php-fpm running" (marionette-eval '(begin (use-modules (gnu services herd)) (start-service 'php-fpm)) marionette)) ;; Wait for nginx to be up and running. (test-assert "nginx running" (marionette-eval '(begin (use-modules (gnu services herd)) (start-service 'nginx)) marionette)) ;; Make sure the PID file is created. (test-assert "nginx PID file" (marionette-eval '(file-exists? "/var/run/nginx/pid") marionette)) ;; Make sure we can access pages that correspond to our Zabbix instance. (letrec-syntax ((test-url (syntax-rules () ((_ path code) (test-equal (string-append "GET " path) code (let-values (((response body) (http-get (string-append "http://localhost:8080" path)))) (response-code response)))) ((_ path) (test-url path 200))))) (test-url "/") (test-url "/does-not-exist" 404)) (test-end) (exit (= (test-runner-fail-count (test-runner-current)) 0))))) (gexp->derivation (string-append name "-test") test)) (define %zabbix-os ;; Return operating system under test. (let ((base-os (simple-operating-system (service dhcp-client-service-type) (service postgresql-service-type (postgresql-configuration (postgresql postgresql))) (service zabbix-front-end-service-type (zabbix-front-end-configuration (db-password "zabbix"))) (service php-fpm-service-type (php-fpm-configuration (timezone "Europe/Paris"))) (service zabbix-server-service-type (zabbix-server-configuration (db-password "zabbix") (log-type "console"))) (service zabbix-agent-service-type)))) (operating-system (inherit base-os) (packages (cons* postgresql (operating-system-packages base-os)))))) (define %test-zabbix (system-test (name "zabbix") (description "Connect to a running Zabbix") (value (run-zabbix-server-test name %zabbix-os))))