aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/prometheus.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 14:03:38 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 14:03:38 +0100
commit1166035acb4e1b0dc61bf9122b68f2afa0c35790 (patch)
tree850cbd3af56ac38a473fa45c4b523fe93ccad2b1 /gnu/packages/prometheus.scm
parent3dfb6df26fa673fe674cf331941506293008ca42 (diff)
downloadguix-1166035acb4e1b0dc61bf9122b68f2afa0c35790.tar.gz
guix-1166035acb4e1b0dc61bf9122b68f2afa0c35790.zip
gnu: go-github-com-prometheus-client-golang: Disable tests on non 64bit architecture.
As seen in CI <https://ci.guix.gnu.org/build/5483940/log/raw>. * gnu/packages/gnu/packages/prometheus.scm (go-github-com-prometheus-client-golang): Disable tests on non 64bit architecture. Change-Id: Ic2f23e1aec24e72056741d4f6fe1fa479bf5e60e
Diffstat (limited to 'gnu/packages/prometheus.scm')
-rw-r--r--gnu/packages/prometheus.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/prometheus.scm b/gnu/packages/prometheus.scm
index b10bb44a5f..71b4646f6a 100644
--- a/gnu/packages/prometheus.scm
+++ b/gnu/packages/prometheus.scm
@@ -142,6 +142,10 @@ registry.")
(build-system go-build-system)
(arguments
(list
+ ;; XXX: Check if the most of the tests may be enabled:
+ ;; api/prometheus/v1/api_test.go:1063:23: cannot use 1634644800304
+ ;; (untyped int constant) as int value in map literal (overflows)
+ #:tests? (target-64bit?)
#:import-path "github.com/prometheus/client_golang"
#:phases
#~(modify-phases %standard-phases