aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-06-04 17:42:30 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-22 13:17:59 +0100
commitfd9599f2b92263337f7821aad5669fd728d34da2 (patch)
tree90deecf7e2ba875c3ea81ab90a452d58d2a753b4 /gnu/packages/perl.scm
parent90cb69dc9203eddaad688dc02a14ed4ead9bf625 (diff)
downloadguix-fd9599f2b92263337f7821aad5669fd728d34da2.tar.gz
guix-fd9599f2b92263337f7821aad5669fd728d34da2.zip
gnu: Add perl-text-iconv.
* gnu/packages/perl.scm (perl-text-iconv): New variable. Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 2fe08d6df5..320c337701 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11703,6 +11703,29 @@ you want to do full file globbing use the File::Glob module instead.")
@url{http://haml.info/docs/yardoc/file.REFERENCE.html} specification.")
(license license:artistic2.0)))
+(define-public perl-text-iconv
+ (package
+ (name "perl-text-iconv")
+ (version "1.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MP/MPIOTR/Text-Iconv-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1hymsbkjkl43wg74p7hgpyjl8yx1chc9g25spj9l7lq9wzavg02v"))))
+ (build-system perl-build-system)
+ (inputs (list libiconv))
+ (home-page "https://metacpan.org/release/Text-Iconv")
+ (synopsis "Perl interface to iconv() codeset conversion function")
+ (description
+ "This module provides a Perl interface to the @code{iconv()} codeset
+conversion function, as defined by the Single UNIX Specification. For
+more details see the POD documentation embedded in the file @file{Iconv.pm},
+which will also be installed as @code{Text::Iconv(3)} man page.")
+ (license license:perl-license)))
+
(define-public perl-text-neattemplate
(package
(name "perl-text-neattemplate")