aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-07-23 22:15:08 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-07-25 09:58:56 +0800
commit999573a69e5928f73a6f4c6dabc2f81ea6b58489 (patch)
treefc16de72237ae175f1f312efb93c5b11afe7e949 /gnu/packages/pdf.scm
parentd41c79c7afb035675a8472d770506addbffdf4be (diff)
downloadguix-999573a69e5928f73a6f4c6dabc2f81ea6b58489.tar.gz
guix-999573a69e5928f73a6f4c6dabc2f81ea6b58489.zip
gnu: zathura-pdf-poppler: Update to 0.3.2.
* gnu/packages/pdf.scm (zathura-pdf-poppler): Update to 0.3.2. [arguments]: Use G-Expressions. Pass "-Dplugindir=..." to configure-flags. Change-Id: Ib76c87267c342007ad8b26e5a9efbcd17a2f488b
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm19
1 files changed, 5 insertions, 14 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 3be620339e..c22c4248bc 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -675,7 +675,7 @@ by using the @code{mupdf} rendering library.")
(define-public zathura-pdf-poppler
(package
(name "zathura-pdf-poppler")
- (version "0.3.1")
+ (version "0.3.2")
(source (origin
(method url-fetch)
(uri
@@ -683,24 +683,15 @@ by using the @code{mupdf} rendering library.")
version ".tar.xz"))
(sha256
(base32
- "12qhkshpp1wjfpjmjccsyi6wscqyqvaa19j85prjpyf65i9jg0gf"))))
+ "049h8m9swxni7ar6fsbm0hb3fg4ffmjc3m6vyg78ilfi3kayxavi"))))
(native-inputs (list pkg-config))
(inputs
(list poppler zathura))
(build-system meson-build-system)
(arguments
- `(#:tests? #f ; package does not include tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-plugin-directory
- ;; Something of a regression in 0.2.9: the new Meson build system
- ;; now hard-codes an incorrect plugin directory. Fix it.
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "meson.build"
- (("(install_dir:).*" _ key)
- (string-append key
- "'" (assoc-ref outputs "out") "/lib/zathura'\n")))
- #t)))))
+ (list #:tests? #f ; package does not include tests
+ #:configure-flags
+ #~(list (string-append "-Dplugindir=" #$output "/lib/zathura"))))
(home-page "https://pwmt.org/projects/zathura-pdf-poppler/")
(synopsis "PDF support for zathura (poppler backend)")
(description "The zathura-pdf-poppler plugin adds PDF support to zathura