aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-10-01 22:12:15 +0200
committerAndrew Tropin <andrew@trop.in>2023-10-02 16:55:04 +0400
commite45f9b4b1251df1a51a30e1d4a53fc2075abfcfe (patch)
tree477ed15d718980f502509ca240671423f3eaf63e /gnu/packages/patches
parent3b71b2dca78c3df3bb6cc952c0911293359a4247 (diff)
downloadguix-e45f9b4b1251df1a51a30e1d4a53fc2075abfcfe.tar.gz
guix-e45f9b4b1251df1a51a30e1d4a53fc2075abfcfe.zip
gnu: emacs-buttercup: Fix native comp tests with emacs-next.
* gnu/packages/emacs-xyz.scm (emacs-buttercup): Add patch emacs-buttercup-fix-native-comp-pretty-test. * gnu/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch: Add file. * gnu/local.mk: Add emacs-buttercup-fix-native-comp-pretty-test.patch. Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch b/gnu/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch
new file mode 100644
index 0000000000..677d5e2303
--- /dev/null
+++ b/gnu/packages/patches/emacs-buttercup-fix-native-comp-pretty-test.patch
@@ -0,0 +1,32 @@
+From 0f822190360a99bac6b532058beb5e20cb2673c3 Mon Sep 17 00:00:00 2001
+From: Nicolas Graves <ngraves@ngraves.fr>
+Date: Sun, 1 Oct 2023 20:20:03 +0200
+Subject: [PATCH] test: Change `pretty' test regexp to pass tests on emacs 30.
+
+---
+ tests/test-buttercup.el | 12 +++++++++---
+ 1 file changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/tests/test-buttercup.el b/tests/test-buttercup.el
+index d68787b..a2e3ba7 100644
+--- a/tests/test-buttercup.el
++++ b/tests/test-buttercup.el
+@@ -2009,9 +2009,15 @@ text properties using `ansi-color-apply'."
+ "suite bc-bt-backtrace\n"
+ "\n"
+ "Traceback (most recent call last):\n"
+- "λ (bc-bt-foo \"" (regex ,long-string) "\")\n"
+- "λ (bc-bt-bar \"" (regex ,long-string) "\")\n"
+- "λ (bc-bt-baz \"" (regex ,long-string) "\")\n"
++ (seq
++ "λ (bc-bt-foo \"" (regex ,long-string) "\")"
++ (optional "\n"))
++ (seq
++ "λ (bc-bt-bar \"" (regex ,long-string) "\")"
++ (optional "\n"))
++ (seq
++ "λ (bc-bt-baz \"" (regex ,long-string) "\")"
++ (optional "\n"))
+ (* (seq (or ?M ?λ) " (" (* not-newline) ; frame start
+ (*? (seq "\n " (* not-newline))) ; any number of pp lines
+ (* not-newline) ")\n")) ;; frame end