aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-12-16 15:25:30 -0500
committerLeo Famulari <leo@famulari.name>2023-12-29 14:57:37 -0500
commitd263c49919235b81b318c45c99aa189be04c5f28 (patch)
treecdabc5489780a05797720caa2fb35943019c2dc6 /gnu/packages/patches
parentceb69872881ed9cdabc0e55c28cca548379dbb5e (diff)
downloadguix-d263c49919235b81b318c45c99aa189be04c5f28.tar.gz
guix-d263c49919235b81b318c45c99aa189be04c5f28.zip
gnu: Transmission: Update to 4.0.5.
* gnu/packages/bittorrent.scm (transmission): Update to 4.0.5. [source]: Use 'transmission-4.0.5-fix-build.patch'. * gnu/packages/patches/transmission-4.0.5-fix-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Change-Id: I8e9486dca07f01628e7886e7ac5757d511056cb7
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/transmission-4.0.5-fix-build.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/patches/transmission-4.0.5-fix-build.patch b/gnu/packages/patches/transmission-4.0.5-fix-build.patch
new file mode 100644
index 0000000000..7eeb0f1921
--- /dev/null
+++ b/gnu/packages/patches/transmission-4.0.5-fix-build.patch
@@ -0,0 +1,39 @@
+Fix the build with gtkmm 4:
+
+https://github.com/transmission/transmission/issues/6392
+
+Patch copied from upstream source repository:
+
+https://github.com/transmission/transmission/commit/e116672b27b314d54514c96b1fa7aef1dee900b1
+
+From e116672b27b314d54514c96b1fa7aef1dee900b1 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?C=C5=93ur?= <coeur@gmx.fr>
+Date: Sun, 17 Dec 2023 16:37:35 +0100
+Subject: [PATCH] fix: build error on GTKMM-4 (#6393)
+
+---
+ gtk/OptionsDialog.cc | 11 ++++++++++-
+ 1 file changed, 10 insertions(+), 1 deletion(-)
+
+diff --git a/gtk/OptionsDialog.cc b/gtk/OptionsDialog.cc
+index 08198540c10..8c28fc76f98 100644
+--- a/gtk/OptionsDialog.cc
++++ b/gtk/OptionsDialog.cc
+@@ -338,7 +338,16 @@ void TorrentFileChooserDialog::onOpenDialogResponse(int response, Glib::RefPtr<S
+ bool const do_prompt = get_choice(std::string(ShowOptionsDialogChoice)) == "true";
+ bool const do_notify = false;
+
+- auto const files = IF_GTKMM4(get_files2, get_files)();
++#if GTKMM_CHECK_VERSION(4, 0, 0)
++ auto files = std::vector<Glib::RefPtr<Gio::File>>();
++ auto files_model = get_files();
++ for (auto i = guint{ 0 }; i < files_model->get_n_items(); ++i)
++ {
++ files.push_back(gtr_ptr_dynamic_cast<Gio::File>(files_model->get_object(i)));
++ }
++#else
++ auto const files = get_files();
++#endif
+ g_assert(!files.empty());
+
+ /* remember this folder the next time we use this dialog */