aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2023-01-28 08:32:31 -0500
committerLudovic Courtès <ludo@gnu.org>2023-03-04 17:30:31 +0100
commita56eafd28bdafda9824a6a85e1ab974b8210f9bb (patch)
tree0aad20f10a712267364a600286535f7ce422bafb /gnu/packages/patches
parentbe41d82d195f2fe2417f46041488b7e09dfc86c4 (diff)
downloadguix-a56eafd28bdafda9824a6a85e1ab974b8210f9bb.tar.gz
guix-a56eafd28bdafda9824a6a85e1ab974b8210f9bb.zip
gnu: mesa: Fix sporadic test failures.
* gnu/packages/patches/mesa-fix-sporadic-test-failures.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gl.scm (mesa)[source]: Apply it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/mesa-fix-sporadic-test-failures.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/mesa-fix-sporadic-test-failures.patch b/gnu/packages/patches/mesa-fix-sporadic-test-failures.patch
new file mode 100644
index 0000000000..50ac5530a2
--- /dev/null
+++ b/gnu/packages/patches/mesa-fix-sporadic-test-failures.patch
@@ -0,0 +1,27 @@
+commit 7749599d737d205a88bbb6fa755ba095d9b581fa
+Author: Gert Wollny <gert.wollny@collabora.com>
+Date: Mon Aug 15 17:15:43 2022 +0200
+
+ r600/sfn: Initialize out buffer when printing op
+
+ 79ca456b4837b3bc21cf9ef3c03c505c4b4909f6
+ r600/sfn: rewrite NIR backend
+
+ Closes: #7021
+
+ Signed-off-by: Gert Wollny <gert.wollny@collabora.com>
+ Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/18130>
+
+diff --git a/src/gallium/drivers/r600/sfn/sfn_instr_export.cpp b/src/gallium/drivers/r600/sfn/sfn_instr_export.cpp
+index 3d40ea1796a..00826ed6457 100644
+--- a/src/gallium/drivers/r600/sfn/sfn_instr_export.cpp
++++ b/src/gallium/drivers/r600/sfn/sfn_instr_export.cpp
+@@ -206,7 +206,7 @@ bool WriteScratchInstr::do_ready() const
+
+ void WriteScratchInstr::do_print(std::ostream& os) const
+ {
+- char buf[6];
++ char buf[6] = {0};
+
+ os << "WRITE_SCRATCH ";
+ if (m_address)