aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-02-19 01:04:38 -0500
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:58 +0200
commit930e1acae8930d1426c9f31844a448f855697b18 (patch)
tree27b805627a0a9d697cff12c9a0124c1f06807aaf /gnu/packages/patches
parent4c8d55ce75b9921bdd06843de71fa8ab03f0f62f (diff)
downloadguix-930e1acae8930d1426c9f31844a448f855697b18.tar.gz
guix-930e1acae8930d1426c9f31844a448f855697b18.zip
gnu: inkscape: Update to 1.3.2.
* gnu/packages/inkscape.scm (inkscape/stable): Update to 1.3.2. Remove patches. [configure-flags]: Add CMAKE_CXX_FLAGS flag. [phases] Remove obsolete patch-icon-cache-generator, disable-latex-export-tests and disable-vertical-glyph-tests phases. Add disable-problematic-tests phase. Override check phase to disable a few test failures caused by the lack of imagemagick. [inputs]: Add gspell and readline. Remove aspell and gtkspell3. (inkscape): Update to 1.3.2. [phases]: Reset the check phase to the original. * gnu/packages/patches/inkscape-poppler-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it. Change-Id: I391fb42db8d93a9cdc83e6fd62ca90f7458b5c49
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/inkscape-poppler-compat.patch45
1 files changed, 0 insertions, 45 deletions
diff --git a/gnu/packages/patches/inkscape-poppler-compat.patch b/gnu/packages/patches/inkscape-poppler-compat.patch
deleted file mode 100644
index cb7d1c8eb3..0000000000
--- a/gnu/packages/patches/inkscape-poppler-compat.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-Fix build with Poppler 22.9.0.
-
-Taken from upstream:
-
- https://gitlab.com/inkscape/inkscape/-/commit/fb00794923d19cfbb2ca4adca3ae8971553a06be
-
-diff --git a/src/extension/internal/pdfinput/pdf-parser.cpp b/src/extension/internal/pdfinput/pdf-parser.cpp
-index cca1e840966c7940a1af472025535042b07e3e0f..80d64c9b866d5d3dd095636a9a02571b89061af1 100644
---- a/src/extension/internal/pdfinput/pdf-parser.cpp
-+++ b/src/extension/internal/pdfinput/pdf-parser.cpp
-@@ -697,7 +697,11 @@ void PdfParser::opSetDash(Object args[], int /*numArgs*/)
- _POPPLER_FREE(obj);
- }
- }
-+#if POPPLER_CHECK_VERSION(22, 9, 0)
-+ state->setLineDash(std::vector<double> (dash, dash + length), args[1].getNum());
-+#else
- state->setLineDash(dash, length, args[1].getNum());
-+#endif
- builder->updateStyle(state);
- }
-
-diff --git a/src/extension/internal/pdfinput/svg-builder.cpp b/src/extension/internal/pdfinput/svg-builder.cpp
-index 12f71dd9214b95dbad6fdf7642a96cdd57f2c64a..9fc56fe63c2feee986ad1ff5018e679a0bacb665 100644
---- a/src/extension/internal/pdfinput/svg-builder.cpp
-+++ b/src/extension/internal/pdfinput/svg-builder.cpp
-@@ -389,10 +389,17 @@ void SvgBuilder::_setStrokeStyle(SPCSSAttr *css, GfxState *state) {
- sp_repr_css_set_property(css, "stroke-miterlimit", os_ml.str().c_str());
-
- // Line dash
-- double *dash_pattern;
- int dash_length;
- double dash_start;
-+#if POPPLER_CHECK_VERSION(22, 9, 0)
-+ const double *dash_pattern;
-+ const std::vector<double> &dash = state->getLineDash(&dash_start);
-+ dash_pattern = dash.data();
-+ dash_length = dash.size();
-+#else
-+ double *dash_pattern;
- state->getLineDash(&dash_pattern, &dash_length, &dash_start);
-+#endif
- if ( dash_length > 0 ) {
- Inkscape::CSSOStringStream os_array;
- for ( int i = 0 ; i < dash_length ; i++ ) {