aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-02-10 18:27:42 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-10 18:27:42 +0100
commit7f31c71cb8f37e0baadb72e3f205ce55037adfba (patch)
treea42e0e8c62e016ddba943327777792c27241be3a /gnu/packages/patches
parentcc0a12822659d2eadaf0401d1660f558da004b4b (diff)
downloadguix-7f31c71cb8f37e0baadb72e3f205ce55037adfba.tar.gz
guix-7f31c71cb8f37e0baadb72e3f205ce55037adfba.zip
gnu: coreutils: Fix cross-compilation issue with 'dummy-man'.
This should work around the bug described at <http://git.yoctoproject.org/cgit.cgi/poky/plain/meta/recipes-core/coreutils/coreutils-8.22/fix-for-dummy-man-usage.patch>. * gnu/packages/base.scm (coreutils)[patches]: Add 'coreutils-dummy-man.patch'. [native-inputs]: Don't pass PERL when (%current-target-system) is true. * gnu/packages/patches/coreutils-dummy-man.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/coreutils-dummy-man.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/coreutils-dummy-man.patch b/gnu/packages/patches/coreutils-dummy-man.patch
new file mode 100644
index 0000000000..6c43389994
--- /dev/null
+++ b/gnu/packages/patches/coreutils-dummy-man.patch
@@ -0,0 +1,17 @@
+Coreutils commit b3578fc9ffe70b9466687f9f6470a85f1a0ab14f.
+
+ * man/dummy-man: Recognize the option --info-page=... as no-op.
+
+This fixes "dummy-man: too many non-option arguments" when
+cross-compiling.
+
+--- a/man/dummy-man
++++ b/man/dummy-man
+@@ -30,6 +30,7 @@ while test $# -gt 0; do
+ # in the makefile.
+ --include=*);;
+ --include) shift;;
++ --info-page=*);;
+ -*) fatal_ "invalid or unrecognized help2man option '$1'";;
+ --) shift; break;;
+ *) break;;