aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-08-08 18:33:10 +0200
committerLudovic Courtès <ludo@gnu.org>2022-08-08 18:33:10 +0200
commit7a485d43c92ea01f7fb64d96d73361a925596abf (patch)
treea1423ce1c6673f3948246b499d19296fed72e69c /gnu/packages/patches
parent3668a452d184d8f373d697bd44ad2eee21b60b38 (diff)
downloadguix-7a485d43c92ea01f7fb64d96d73361a925596abf.tar.gz
guix-7a485d43c92ea01f7fb64d96d73361a925596abf.zip
gnu: ruby-hydra-minimal: Add missing patch.
This is a followup to bb907402a613494e7fb6f8f04bf8d9d16ff9ee66. * gnu/packages/patches/ruby-hydra-minimal-no-byebug.patch: New file.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ruby-hydra-minimal-no-byebug.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/patches/ruby-hydra-minimal-no-byebug.patch b/gnu/packages/patches/ruby-hydra-minimal-no-byebug.patch
new file mode 100644
index 0000000000..7b338ca03e
--- /dev/null
+++ b/gnu/packages/patches/ruby-hydra-minimal-no-byebug.patch
@@ -0,0 +1,11 @@
+Description: Avoid dependency on byebug to reduce package closure
+ significantly, see https://issues.guix.gnu.org/55997
+diff --git a/lib/hydra.rb b/lib/hydra.rb
+index 29fbad2..6b5058a 100644
+--- a/lib/hydra.rb
++++ b/lib/hydra.rb
+@@ -1,4 +1,3 @@
+-require 'byebug' unless ENV['RACK_ENV'] == "production"
+ require 'pp'
+
+ module CoreExt