aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-24 00:07:32 +0200
committerMarius Bakke <marius@gnu.org>2022-06-24 00:07:32 +0200
commit66e3adcad8cb07962d75e89d562057ded9946348 (patch)
treeff863116793a8561c1a904db833edda1a3e7ff6f /gnu/packages/patches
parent6c7fcc71d170f71db907c3c456266d0e8a1448aa (diff)
downloadguix-66e3adcad8cb07962d75e89d562057ded9946348.tar.gz
guix-66e3adcad8cb07962d75e89d562057ded9946348.zip
gnu: Remove unused patch.
This is a follow-up to commit fce910af555b72d02ba868885571b2fdc38b2d5f. * gnu/packages/patches/postgresql-riscv-spinlocks.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/postgresql-riscv-spinlocks.patch41
1 files changed, 0 insertions, 41 deletions
diff --git a/gnu/packages/patches/postgresql-riscv-spinlocks.patch b/gnu/packages/patches/postgresql-riscv-spinlocks.patch
deleted file mode 100644
index 984a573642..0000000000
--- a/gnu/packages/patches/postgresql-riscv-spinlocks.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-https://www.postgresql.org/message-id/dea97b6d-f55f-1f6d-9109-504aa7dfa421@gentoo.org
-
-The attached patch adds native spinlock support to PostgreSQL on RISC-V
-systems. As suspected by Richard W.M. Jones of Red Hat back in 2016, the
-__sync_lock_test_and_set() approach applied on arm and arm64 works here
-as well.
-
-
-Tested against PostgreSQL 13.3 on a physical rv64gc system (BeagleV
-Starlight beta board) - builds and installs fine, all tests pass. From
-what I can see in gcc documentation this should in theory work on rv32
-(and possibly rv128) as well, therefore the patch as it stands covers
-all RISC-V systems (i.e. doesn't check the value of __risc_xlen) - but I
-haven't confirmed this experimentally.
-
---- a/src/include/storage/s_lock.h
-+++ b/src/include/storage/s_lock.h
-@@ -315,12 +315,12 @@
- #endif /* __ia64__ || __ia64 */
-
- /*
-- * On ARM and ARM64, we use __sync_lock_test_and_set(int *, int) if available.
-+ * On ARM, ARM64 and RISC-V, we use __sync_lock_test_and_set(int *, int) if available.
- *
- * We use the int-width variant of the builtin because it works on more chips
- * than other widths.
- */
--#if defined(__arm__) || defined(__arm) || defined(__aarch64__) || defined(__aarch64)
-+#if defined(__arm__) || defined(__arm) || defined(__aarch64__) || defined(__aarch64) || defined(__riscv)
- #ifdef HAVE_GCC__SYNC_INT32_TAS
- #define HAS_TEST_AND_SET
-
-@@ -337,7 +337,7 @@
- #define S_UNLOCK(lock) __sync_lock_release(lock)
-
- #endif /* HAVE_GCC__SYNC_INT32_TAS */
--#endif /* __arm__ || __arm || __aarch64__ || __aarch64 */
-+#endif /* __arm__ || __arm || __aarch64__ || __aarch64 || __riscv */
-
-
- /* S/390 and S/390x Linux (32- and 64-bit zSeries) */