aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-10 18:12:18 +0200
committerLudovic Courtès <ludo@gnu.org>2015-06-10 21:58:16 +0200
commit57cd353d87d6e9e6e882327be70b4d7b5ce863ba (patch)
tree2bbb2bca999bd0f47aabcfbf9186a61465c02291 /gnu/packages/patches
parent7887bcbf56f8ef154ba987e67e457c8695254fa5 (diff)
downloadguix-57cd353d87d6e9e6e882327be70b4d7b5ce863ba.tar.gz
guix-57cd353d87d6e9e6e882327be70b4d7b5ce863ba.zip
build: Build man pages after the corresponding code.
* doc.am (doc/guix.1): Remove extraneous $(top_builddir)/. (doc/guix-daemon.1): Fix dependency. (doc/guix-$(1).1): Remove extraneous $(top_builddir)/. Depend on the .go files instead of the .scm file. Add dependency on scripts/guix.
Diffstat (limited to 'gnu/packages/patches')
0 files changed, 0 insertions, 0 deletions
:09.395212502 -0400
+@@ -2718,6 +2718,7 @@
+ chatty=True, connectionchatty=True)
+ self.assertIs(stats['compression'], None)
+
++ @unittest.skipIf(True, "openssl 1.0.2b complains: dh key too small")
+ def test_dh_params(self):
+ # Check we can get a connection with ephemeral Diffie-Hellman
+ context = ssl.SSLContext(ssl.PROTOCOL_TLSv1)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 914c2dc23c..232a785778 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -207,7 +207,9 @@ data types.")
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
version "/Python-" version ".tar.xz"))
- (patches (list (search-patch "python-fix-tests.patch")))
+ (patches (list (search-patch "python-fix-tests.patch")
+ ;; XXX Try removing this patch for python > 3.4.3
+ (search-patch "python-disable-ssl-test.patch")))
(patch-flags '("-p0"))
(sha256
(base32