aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:06:09 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:09 +0200
commit4a82b3f92e0f301d0677bacf4918720093a64165 (patch)
tree4161d911a4442abb5bca600e407a5dbcdc338781 /gnu/packages/patches
parent1ddb4dde8b1bf2f59c1bfda233bb3606ca062d75 (diff)
downloadguix-4a82b3f92e0f301d0677bacf4918720093a64165.tar.gz
guix-4a82b3f92e0f301d0677bacf4918720093a64165.zip
gnu: dblatex: Fix missing texlive binaries and fig2dev.
The binaries for dblatex aren't provided by texlive-updmap.cfg but by texlive-bin. * gnu/packages/patches/dblatex-inkscape-1.0.patch: New file. * gnu/local.mk: Register it. * gnu/packages/docbook.scm (dblatex)[source]: Use dblatex-inkscape-1.0.patch. [arguments]<#:tests?>: Enable tests. <#:phases>: Rename 'set-path to 'wrap-dblatex. Wrap with texlive-bin rather than texlive-updmap.cfg in PATH and wrap GUIX_TEXMF in 'wrap-dblatex. Add 'check-wrap phase. [native-inputs]: Add docbook-mathml-1.0. [inputs]: Restyle. Add texlive-bin. Replace inkscape/stable with inkscape. Within texlive-updmap.cfg add previously missing: texlive-amsmath, texlive-auxhook, texlive-bigintcalc, texlive-bin, texlive-bitset, texlive-bookmark, texlive-colortbl, texlive-courier, texlive-eepic, texlive-epstopdf-pkg, texlive-eso-pic, texlive-etexcmds, texlive-fancyhdr, texlive-gettitlestring, texlive-graphics, texlive-graphics-cfg, texlive-helvetic, texlive-hycolor, texlive-hyperref, texlive-infwarerr, texlive-intcalc, texlive-kpathsea, texlive-kvdefinekeys, texlive-kvoptions, texlive-kvsetkeys, texlive-l3backend, texlive-latex, texlive-latex-bin, texlive-letltxmacro, texlive-ltxcmds, texlive-pdfescape, texlive-pdflscape, texlive-pdftexcmds, texlive-psnfss, texlive-rerunfilecheck, texlive-symbol, texlive-times, texlive-tools, texlive-uniquecounter, texlive-url and texlive-zapfding. Add fig2dev. (dblatex/stable)[inputs]: Replace inkscape with inkscape/stable. Co-authored-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I4fb2e1f894b98a4e33a0438a1dda569eeb9eae81
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/dblatex-inkscape-1.0.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/patches/dblatex-inkscape-1.0.patch b/gnu/packages/patches/dblatex-inkscape-1.0.patch
new file mode 100644
index 0000000000..634c99481a
--- /dev/null
+++ b/gnu/packages/patches/dblatex-inkscape-1.0.patch
@@ -0,0 +1,39 @@
+# Imported from <https://sourceforge.net/p/dblatex/dblatex/merge-requests/4/>
+
+# HG changeset patch
+# User Jan Tojnar <jtojnar@gmail.com>
+# Date 1588714251 -7200
+# Tue May 05 23:30:51 2020 +0200
+# Branch inkscape1
+# Node ID 611cc4a4a878d57f5877f2d418864560f68d25cf
+# Parent 3ddf5d6cedcbc9c8b98c4da77fd545b2478d90a3
+Port to Inkscape 1.0
+
+Inkscape revamped the CLI flags:
+
+https://gitlab.com/inkscape/inbox/issues/2416
+
+diff -r 3ddf5d6cedcb -r 611cc4a4a878 docs/custom/dblatex.xconf
+--- a/docs/custom/dblatex.xconf Tue Sep 10 00:40:26 2019 +0200
++++ b/docs/custom/dblatex.xconf Tue May 05 23:30:51 2020 +0200
+@@ -18,7 +18,7 @@
+ <imagedata>
+ <converter src="svg" dst="*" docformat="pdf">
+ <command>
+- inkscape -z -D --export-dpi=600 --export-%(dst)s=%(output)s %(input)s
++ inkscape -D --export-dpi=600 --export-type=%(dst)s --export-filename=%(output)s %(input)s
+ </command>
+ </converter>
+ </imagedata>
+diff -r 3ddf5d6cedcb -r 611cc4a4a878 lib/dbtexmf/core/imagedata.py
+--- a/lib/dbtexmf/core/imagedata.py Tue Sep 10 00:40:26 2019 +0200
++++ b/lib/dbtexmf/core/imagedata.py Tue May 05 23:30:51 2020 +0200
+@@ -178,7 +178,7 @@
+ class SvgConverter(ImageConverter):
+ def __init__(self, imgsrc, imgdst="", docformat="", backend=""):
+ ImageConverter.__init__(self, imgsrc="svg", imgdst=imgdst)
+- self.add_command(["inkscape", "-z", "-D", "--export-%(dst)s=%(output)s",
++ self.add_command(["inkscape", "-D", "--export-type=%(dst)s", "--export-filename=%(output)s",
+ "%(input)s"])
+
+