aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2023-03-07 04:43:01 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-07 11:18:50 +0100
commit26e9725c54df48eda8282e6716a7581a7755f8f9 (patch)
tree88413a59b1f7ce0c5e348708e1a72545a09c804d /gnu/packages/patches
parent79da3b19f0c9b506f58767159dd7a24d835fdce0 (diff)
downloadguix-26e9725c54df48eda8282e6716a7581a7755f8f9.tar.gz
guix-26e9725c54df48eda8282e6716a7581a7755f8f9.zip
gnu: Add cl-eazy-gnuplot.
* gnu/packages/lisp-xyz.scm (sbcl-eazy-gnuplot, cl-eazy-gnuplot, ecl-eazy-gnuplot): New variables. * gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch b/gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch
new file mode 100644
index 0000000000..ccc9c09fb9
--- /dev/null
+++ b/gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch
@@ -0,0 +1,14 @@
+Don't check whether gnuplot is present in $PATH, because we know it is.
+
+diff --git a/eazy-gnuplot.asd b/eazy-gnuplot.asd
+index 7b1c09b..4657cd6 100644
+--- a/eazy-gnuplot.asd
++++ b/eazy-gnuplot.asd
+@@ -37,7 +37,4 @@
+ :fill-pointer t)))
+ (setf (fill-pointer seq) (read-sequence seq stream))
+ seq)))
+- :perform (load-op :before (op c)
+- (unless (zerop (nth-value 2 (uiop:run-program "which gnuplot" :ignore-error-status t)))
+- (warn "Could not find GNUPLOT in $PATH")))
+ :in-order-to ((test-op (test-op eazy-gnuplot.test))))