aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ytnef-CVE-2021-3403.patch
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:08 +0200
commit1290fce44db244967d204a675c0dc2bb8dc75732 (patch)
tree46df23ea77e9fb2812af7cfb51d93a7594a69fa4 /gnu/packages/patches/ytnef-CVE-2021-3403.patch
parenta927a9e25b4a269c9f76ca9f424750466e2e2daa (diff)
downloadguix-1290fce44db244967d204a675c0dc2bb8dc75732.tar.gz
guix-1290fce44db244967d204a675c0dc2bb8dc75732.zip
gnu: ytnef: Update to 2.0.
* gnu/packages/mail.scm (ytnef): Update to 2.0. [source]: Remove patches. * gnu/packages/patches/ytnef-CVE-2021-3403.patch, gnu/packages/patches/ytnef-CVE-2021-3404.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/patches/ytnef-CVE-2021-3403.patch')
-rw-r--r--gnu/packages/patches/ytnef-CVE-2021-3403.patch32
1 files changed, 0 insertions, 32 deletions
diff --git a/gnu/packages/patches/ytnef-CVE-2021-3403.patch b/gnu/packages/patches/ytnef-CVE-2021-3403.patch
deleted file mode 100644
index 4b1c9d659f..0000000000
--- a/gnu/packages/patches/ytnef-CVE-2021-3403.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From f2380a53fb84d370eaf6e6c3473062c54c57fac7 Mon Sep 17 00:00:00 2001
-From: Oliver Giles <ohw.giles@gmail.com>
-Date: Mon, 1 Feb 2021 10:12:16 +1300
-Subject: [PATCH] Prevent potential double-free in TNEFSubjectHandler
-
-If TNEFSubjectHandler is called multiple times, but the last time
-failed due to the PREALLOCCHECK, the subject.data member will be
-a freed, but invalid pointer. To prevent a double-free next time
-TNEFSubjectHandler is entered, set it to zero after freeing.
-
-Resolves: #85
-Reported-by: jasperla
----
- lib/ytnef.c | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/lib/ytnef.c b/lib/ytnef.c
-index b148719..b06c807 100644
---- a/lib/ytnef.c
-+++ b/lib/ytnef.c
-@@ -301,8 +301,10 @@ int TNEFFromHandler STD_ARGLIST {
- }
- // -----------------------------------------------------------------------------
- int TNEFSubjectHandler STD_ARGLIST {
-- if (TNEF->subject.data)
-+ if (TNEF->subject.data) {
- free(TNEF->subject.data);
-+ TNEF->subject.data = NULL;
-+ }
-
- PREALLOCCHECK(size, 100);
- TNEF->subject.data = calloc(size+1, sizeof(BYTE));