aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/wicd-template-instantiation.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-09 15:40:14 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-09 23:53:36 +0200
commit6f05630ba6848fa666f4ea57aab7f7ffbc15fc72 (patch)
treebcff6abefe3edb24289fffb095b4cd4409526388 /gnu/packages/patches/wicd-template-instantiation.patch
parent15f0de0581987c539f86012bf524559e283f5942 (diff)
downloadguix-6f05630ba6848fa666f4ea57aab7f7ffbc15fc72.tar.gz
guix-6f05630ba6848fa666f4ea57aab7f7ffbc15fc72.zip
gnu: wicd: Add patch to fix template instantiation.
* gnu/packages/patches/wicd-template-instantiation.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/wicd.scm (wicd)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches/wicd-template-instantiation.patch')
-rw-r--r--gnu/packages/patches/wicd-template-instantiation.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/patches/wicd-template-instantiation.patch b/gnu/packages/patches/wicd-template-instantiation.patch
new file mode 100644
index 0000000000..16d8fa6e1d
--- /dev/null
+++ b/gnu/packages/patches/wicd-template-instantiation.patch
@@ -0,0 +1,29 @@
+Wicd 1.7.3 fails to instantiate template lines that have several
+variable references. For instance, the line:
+
+ wep_key$_KEY_INDEX=$_KEY
+
+which is found in in the 'wep-hex' template, expands to these two
+lines:
+
+ wep_key0=$_KEY
+ wep_key0=123456789ab
+
+This patch fixes that by only emitting the fully substituted line.
+
+Patch by Ludovic Courtès <ludo@gnu.org>.
+
+--- a/wicd/misc.py 2012-11-17 00:07:08 +0000
++++ b/wicd/misc.py 2015-05-09 11:22:37 +0000
+@@ -321,11 +321,11 @@ def ParseEncryption(network):
+ rep_val = '0'
+ if rep_val:
+ line = line.replace("$_%s" % cur_val, str(rep_val))
+- config_file = ''.join([config_file, line])
+ else:
+ print "Ignoring template line: '%s'" % line
+ else:
+ print "Weird parsing error occurred"
++ config_file = ''.join([config_file, line])
+ else: # Just a regular entry.
+ config_file = ''.join([config_file, line])