aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/vtk-7-gcc-11-compat.patch
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-09 12:22:14 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-09 12:22:14 +0200
commit94ca5b4357af8f8921f0cb0873a7cf316f13aa69 (patch)
tree6ef30120737f26f298f7f17d86597b0b729517e0 /gnu/packages/patches/vtk-7-gcc-11-compat.patch
parent6750c114e3e988249f4069d0180316c6d0192350 (diff)
parentdb61bdd7f52270a35bd0a3a88650d98276dab20b (diff)
downloadguix-94ca5b4357af8f8921f0cb0873a7cf316f13aa69.tar.gz
guix-94ca5b4357af8f8921f0cb0873a7cf316f13aa69.zip
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/patches/vtk-7-gcc-11-compat.patch')
-rw-r--r--gnu/packages/patches/vtk-7-gcc-11-compat.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/patches/vtk-7-gcc-11-compat.patch b/gnu/packages/patches/vtk-7-gcc-11-compat.patch
new file mode 100644
index 0000000000..c7ab3af36e
--- /dev/null
+++ b/gnu/packages/patches/vtk-7-gcc-11-compat.patch
@@ -0,0 +1,11 @@
+Description: GCC 11 now enforces that comparison objects be invocable as const.
+--- a/Rendering/Label/vtkLabelHierarchy.cxx
++++ b/Rendering/Label/vtkLabelHierarchy.cxx
+@@ -525,1 +525,1 @@
+- const vtkHierarchyNode & b)
++ const vtkHierarchyNode & b) const
+--- a/Rendering/Label/vtkLabelHierarchyPrivate.h
++++ b/Rendering/Label/vtkLabelHierarchyPrivate.h
+@@ -66,1 +66,1 @@
+- bool operator () ( const vtkIdType& a, const vtkIdType& b )
++ bool operator () ( const vtkIdType& a, const vtkIdType& b ) const