aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/racket-rktboot-riscv64-support.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-19 21:04:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-21 13:19:30 +0300
commit261422e7451901d99c6cfcbaa5e0037117588f34 (patch)
tree254aeb707d08f9864be688dd0441a62ebc788ad2 /gnu/packages/patches/racket-rktboot-riscv64-support.patch
parent182be30fb1a8b847c30492462ec22c08ec7a9849 (diff)
downloadguix-261422e7451901d99c6cfcbaa5e0037117588f34.tar.gz
guix-261422e7451901d99c6cfcbaa5e0037117588f34.zip
chez-sheme-for-racket: Fix building on riscv64-linux.
* gnu/packages/racket.scm (%racket-origin): Add patch. * gnu/packages/patches/racket-rktboot-riscv64-support.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches/racket-rktboot-riscv64-support.patch')
-rw-r--r--gnu/packages/patches/racket-rktboot-riscv64-support.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/racket-rktboot-riscv64-support.patch b/gnu/packages/patches/racket-rktboot-riscv64-support.patch
new file mode 100644
index 0000000000..f268b1e7f8
--- /dev/null
+++ b/gnu/packages/patches/racket-rktboot-riscv64-support.patch
@@ -0,0 +1,15 @@
+Submitted upstream:
+https://github.com/racket/racket/pull/4703
+
+diff --git a/racket/src/rktboot/machine-def.rkt b/racket/src/rktboot/machine-def.rkt
+index 8ff0688..59ebfc8 100644
+--- a/racket/src/rktboot/machine-def.rkt
++++ b/racket/src/rktboot/machine-def.rkt
+@@ -25,6 +25,7 @@
+ [(regexp-match? #rx"^t?arm32" target-machine) "arm32"]
+ [(regexp-match? #rx"^t?arm64" target-machine) "arm64"]
+ [(regexp-match? #rx"^t?ppc32" target-machine) "ppc32"]
++ [(regexp-match? #rx"^t?rv64" target-machine) "rv64"]
+ [(regexp-match? #rx"^t?pb" target-machine) "pb"]
+ [else (error "machine.def: cannot infer architecture")]))]
+ [s (regexp-replace* #rx"[$][(]Mend[)]" s