aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-2-deterministic-build-info.patch
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-10-25 13:32:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-10-25 13:33:12 +0200
commitaabfddbe8bc16fa82067e88e7d79c8c1bc802414 (patch)
treeaafc2e0be401ac558042b3c4034421056a5108b9 /gnu/packages/patches/python-2-deterministic-build-info.patch
parentc6d2bb9d0a1e7e74af3984b7dad1ffacff20768c (diff)
downloadguix-aabfddbe8bc16fa82067e88e7d79c8c1bc802414.tar.gz
guix-aabfddbe8bc16fa82067e88e7d79c8c1bc802414.zip
gnu: Add r-ggdist.
* gnu/packages/cran.scm (r-ggdist): New variable. Change-Id: Ia9f57e1efcbb9df08a79d9e51bc438fa64fe61e2
Diffstat (limited to 'gnu/packages/patches/python-2-deterministic-build-info.patch')
0 files changed, 0 insertions, 0 deletions
9fpwhb3km8c3z53bja5b7ic3sb2z6dgz"))))
- (build-system python-build-system)
+ (base32 "0nxp4z81vykv07kv2b6zrwk7ns8s10zqsb7vcignp8695yq3nlcm"))))
+ (build-system pyproject-build-system)
(arguments
- ;; TODO: Package missing test dependencies.
(list
- #:tests? #f
+ #:test-flags
+ '(list
+ ;; We have no TES support.
+ "--ignore=tests/test_tes.py"
+ ;; This test attempts to change S3 buckets on AWS and fails
+ ;; because there are no AWS credentials.
+ "--ignore=tests/test_tibanna.py"
+ ;; It's a similar story with this test, which requires access
+ ;; to the Google Storage service.
+ "--ignore=tests/test_google_lifesciences.py")
#:phases
#~(modify-phases %standard-phases
;; For cluster execution Snakemake will call Python. Since there is
@@ -13218,7 +13229,9 @@ approach.")
(lambda _
(substitute* "snakemake/executors/__init__.py"
(("\\{sys.executable\\} -m snakemake")
- (string-append #$output "/bin/snakemake"))))))))
+ (string-append #$output "/bin/snakemake")))))
+ (add-before 'check 'pre-check
+ (lambda _ (setenv "HOME" "/tmp"))))))
(propagated-inputs
(list python-appdirs
python-configargparse
@@ -13236,6 +13249,12 @@ approach.")
python-requests
python-toposort
python-wrapt))
+ (native-inputs
+ (list git-minimal
+ python-wrapper
+ python-pytest
+ python-pandas
+ python-requests-mock))
(home-page "https://snakemake.readthedocs.io")
(synopsis "Python-based execution environment for make-like workflows")
(description