aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/onnx-shared-libraries.patch
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2024-08-04 22:15:54 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-06 11:46:25 +0200
commit595cc594b65ffe4a55c8b8d53a91a841cf056103 (patch)
treee07864d9d077f9e4c1f86c48b051d225b56cd8c6 /gnu/packages/patches/onnx-shared-libraries.patch
parent852c75a125273f4d3c3e540497f3b5e825468362 (diff)
downloadguix-595cc594b65ffe4a55c8b8d53a91a841cf056103.tar.gz
guix-595cc594b65ffe4a55c8b8d53a91a841cf056103.zip
gnu: onnx: Update to 1.16.2.
* gnu/packages/machine-learning.scm (onnx): Update to 1.16.2. [source]: Remove patch. [build-system]: Move to pyproject-build-system. [arguments]<#:tests?>: Disable for systems where python-nbval is not supported. <#:phases>: Remove 'relax-requirements' phase. Pass "-DONNX_BUILD_TESTS" to CMake depending on tests?. [native-inputs]: Add python-fb-re2 and python-parameterized-next. Remove python-nbval on unsupported systems. * gnu/packages/patches/onnx-shared-libraries.patch: Adjust patch. * gnu/packages/patches/onnx-skip-model-downloads.patch: Adjust patch. * gnu/packages/patches/onnx-use-system-googletest.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Co-authored-by: Andy Tai <atai@atai.org>
Diffstat (limited to 'gnu/packages/patches/onnx-shared-libraries.patch')
-rw-r--r--gnu/packages/patches/onnx-shared-libraries.patch18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/patches/onnx-shared-libraries.patch b/gnu/packages/patches/onnx-shared-libraries.patch
index 00583b35da..5a3fd658d0 100644
--- a/gnu/packages/patches/onnx-shared-libraries.patch
+++ b/gnu/packages/patches/onnx-shared-libraries.patch
@@ -1,13 +1,12 @@
-These linker options for the 'onnx_cpp2py_export.cpython-38-*-gnu.so'
-(or similar) extension are meant to be used when building 'libonn.a',
-a static archive. This patch adapts the link flags to linking with
-'libonnx.so'.
+These linker options for the 'onnx_cpp2py_export.cpython-310-*-gnu.so' (or
+similar) extension are meant to be used when building 'libonn.a', a static
+archive. This patch adapts the link flags to linking with 'libonnx.so'.
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index cede3073..52f846ed 100644
+index b666eec4..1525b219 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -475,11 +475,10 @@ if(BUILD_ONNX_PYTHON)
+@@ -585,16 +585,15 @@ if(BUILD_ONNX_PYTHON)
PRIVATE $<TARGET_OBJECTS:onnx>)
else()
# Assume everything else is like gcc
@@ -15,10 +14,15 @@ index cede3073..52f846ed 100644
- PRIVATE "-Wl,--whole-archive" $<TARGET_FILE:onnx>
- "-Wl,--no-whole-archive")
+ target_link_libraries(onnx_cpp2py_export PRIVATE onnx)
+ # Prevent "undefined symbol: _ZNSt10filesystem7__cxx114path14_M_split_cmptsEv"
+ # (std::filesystem::__cxx11::path::_M_split_cmpts()) on gcc 8
+ if (CMAKE_CXX_STANDARD EQUAL 17 AND CMAKE_COMPILER_IS_GNUCC AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 9.0)
+ target_link_libraries(onnx_cpp2py_export PRIVATE "-lstdc++fs")
+ endif()
set_target_properties(onnx_cpp2py_export
- PROPERTIES LINK_FLAGS "-Wl,--exclude-libs,ALL")
+ PROPERTIES LINK_FLAGS
-+ "-Wl,-rpath=${CMAKE_INSTALL_PREFIX}/lib")
++ "-Wl,-rpath=${CMAKE_INSTALL_PREFIX}/lib")
endif()
target_link_libraries(onnx_cpp2py_export PRIVATE onnx)