aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mono-5.8.0-patches.patch
diff options
context:
space:
mode:
authorunmush <unmush@hashbang.sh>2024-11-27 00:47:09 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-12-22 15:37:35 +0200
commit27d7d879b79230143c81b114d98fd977325ea36b (patch)
tree923dd217efe28dfd1aa80a48165886a2621a03b0 /gnu/packages/patches/mono-5.8.0-patches.patch
parentb0ef15d7f41ace2d15cbef64b85d92fa20d154d3 (diff)
downloadguix-27d7d879b79230143c81b114d98fd977325ea36b.tar.gz
guix-27d7d879b79230143c81b114d98fd977325ea36b.zip
gnu: Add mono-5.8.0.
* gnu/packages/dotnet.scm (mono-5.8.0-external-repo-specs, mono-5.8.0): New variables. * gnu/packages/patches/mono-5.8.0-patches.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register new patch. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: Ibb7379d4b3dacd6c40418510da7b6f203ded812f
Diffstat (limited to 'gnu/packages/patches/mono-5.8.0-patches.patch')
-rw-r--r--gnu/packages/patches/mono-5.8.0-patches.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/patches/mono-5.8.0-patches.patch b/gnu/packages/patches/mono-5.8.0-patches.patch
new file mode 100644
index 0000000000..f73c51d92f
--- /dev/null
+++ b/gnu/packages/patches/mono-5.8.0-patches.patch
@@ -0,0 +1,60 @@
+diff --git a/mcs/class/System/Mono.AppleTls/AppleTlsContext.cs b/mcs/class/System/Mono.AppleTls/AppleTlsContext.cs
+index 0cc69e47648..51ded713ba6 100644
+--- a/mcs/class/System/Mono.AppleTls/AppleTlsContext.cs
++++ b/mcs/class/System/Mono.AppleTls/AppleTlsContext.cs
+@@ -775,7 +775,7 @@ namespace Mono.AppleTls
+ [DllImport (SecurityLibrary)]
+ extern unsafe static /* OSStatus */ SslStatus SSLRead (/* SSLContextRef */ IntPtr context, /* const void* */ byte* data, /* size_t */ IntPtr dataLength, /* size_t* */ out IntPtr processed);
+
+- public override unsafe (int ret, bool wantMore) Read (byte[] buffer, int offset, int count)
++ public override unsafe System.ValueTuple<int, bool> Read (byte[] buffer, int offset, int count)
+ {
+ if (Interlocked.Exchange (ref pendingIO, 1) == 1)
+ throw new InvalidOperationException ();
+@@ -816,7 +816,7 @@ namespace Mono.AppleTls
+ [DllImport (SecurityLibrary)]
+ extern unsafe static /* OSStatus */ SslStatus SSLWrite (/* SSLContextRef */ IntPtr context, /* const void* */ byte* data, /* size_t */ IntPtr dataLength, /* size_t* */ out IntPtr processed);
+
+- public override unsafe (int ret, bool wantMore) Write (byte[] buffer, int offset, int count)
++ public override unsafe System.ValueTuple<int, bool> Write (byte[] buffer, int offset, int count)
+ {
+ if (Interlocked.Exchange (ref pendingIO, 1) == 1)
+ throw new InvalidOperationException ();
+diff --git a/mcs/class/System/Mono.Btls/MonoBtlsContext.cs b/mcs/class/System/Mono.Btls/MonoBtlsContext.cs
+index 559db4aca5d..b70239c5163 100644
+--- a/mcs/class/System/Mono.Btls/MonoBtlsContext.cs
++++ b/mcs/class/System/Mono.Btls/MonoBtlsContext.cs
+@@ -300,7 +300,7 @@ namespace Mono.Btls
+ throw new NotImplementedException ();
+ }
+
+- public override (int ret, bool wantMore) Read (byte[] buffer, int offset, int size)
++ public override System.ValueTuple<int, bool> Read (byte[] buffer, int offset, int size)
+ {
+ Debug ("Read: {0} {1} {2}", buffer.Length, offset, size);
+
+@@ -329,7 +329,7 @@ namespace Mono.Btls
+ }
+ }
+
+- public override (int ret, bool wantMore) Write (byte[] buffer, int offset, int size)
++ public override System.ValueTuple<int, bool> Write (byte[] buffer, int offset, int size)
+ {
+ Debug ("Write: {0} {1} {2}", buffer.Length, offset, size);
+
+diff --git a/mcs/class/System/Mono.Net.Security/MobileTlsContext.cs b/mcs/class/System/Mono.Net.Security/MobileTlsContext.cs
+index 74410976a85..46f0eb59b9c 100644
+--- a/mcs/class/System/Mono.Net.Security/MobileTlsContext.cs
++++ b/mcs/class/System/Mono.Net.Security/MobileTlsContext.cs
+@@ -165,9 +165,9 @@ namespace Mono.Net.Security
+
+ public abstract void Flush ();
+
+- public abstract (int ret, bool wantMore) Read (byte[] buffer, int offset, int count);
++ public abstract System.ValueTuple<int, bool> Read (byte[] buffer, int offset, int count);
+
+- public abstract (int ret, bool wantMore) Write (byte[] buffer, int offset, int count);
++ public abstract System.ValueTuple<int, bool> Write (byte[] buffer, int offset, int count);
+
+ public abstract void Shutdown ();
+