aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ghc-testsuite-grep-compat.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-09 20:49:55 +0200
committerMarius Bakke <marius@gnu.org>2022-09-10 16:55:05 +0200
commitb4693f4a58b977c92282c81d3032f5be990e866a (patch)
tree38d2d1b75a7fa43c166b366933459deffb1f5e3b /gnu/packages/patches/ghc-testsuite-grep-compat.patch
parent77bd6accabe03a9e570697bd12b64ef4e9cffe20 (diff)
downloadguix-b4693f4a58b977c92282c81d3032f5be990e866a.tar.gz
guix-b4693f4a58b977c92282c81d3032f5be990e866a.zip
gnu: GHC: Adjust tests for grep 3.8.
This fixes a test failure introduced in commit c527b0ce23c5d9228d29c5f90892aa5f05e77347. * gnu/packages/patches/ghc-testsuite-grep-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/haskell.scm (ghc-8.6, ghc-8.8, ghc-8.10)[native-inputs]: Patch the 'ghc-testsuite' input.
Diffstat (limited to 'gnu/packages/patches/ghc-testsuite-grep-compat.patch')
-rw-r--r--gnu/packages/patches/ghc-testsuite-grep-compat.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/patches/ghc-testsuite-grep-compat.patch b/gnu/packages/patches/ghc-testsuite-grep-compat.patch
new file mode 100644
index 0000000000..a2bd5fcec4
--- /dev/null
+++ b/gnu/packages/patches/ghc-testsuite-grep-compat.patch
@@ -0,0 +1,39 @@
+Remove stray escapes to avoid warnings from grep 3.8 which breaks
+expected test output.
+
+diff --git a/testsuite/tests/hsc2hs/Makefile b/testsuite/tests/hsc2hs/Makefile
+--- a/testsuite/tests/hsc2hs/Makefile
++++ b/testsuite/tests/hsc2hs/Makefile
+@@ -47,5 +47,5 @@ T12504:
+ ifeq "$(WINDOWS)" "YES"
+ grep '{-# LINE 1 \"T12504\\\\path\\\\to\\\\$@\.hsc\" #-}' T12504/path/to/$@.hs
+ else
+- grep '{-# LINE 1 \"T12504/path/to/$@\.hsc\" #-}' T12504/path/to/$@.hs
++ grep '{-# LINE 1 "T12504/path/to/$@\.hsc" #-}' T12504/path/to/$@.hs
+ endif
+diff --git a/testsuite/tests/numeric/should_run/T7014.primops b/testsuite/tests/numeric/should_run/T7014.primops
+--- a/testsuite/tests/numeric/should_run/T7014.primops
++++ b/testsuite/tests/numeric/should_run/T7014.primops
+@@ -1,8 +1,8 @@
+ and#
+ or#
+ uncheckedShift.*#
+-\+#
+-\-#
+++#
++-#
+ \*#
+ quotInt#
+ remInt#
+diff --git a/testsuite/tests/simplCore/should_compile/Makefile b/testsuite/tests/simplCore/should_compile/Makefile
+--- a/testsuite/tests/simplCore/should_compile/Makefile
++++ b/testsuite/tests/simplCore/should_compile/Makefile
+@@ -226,7 +226,7 @@ str-rules:
+ # g should have been collapsed into one defininition by CSE.
+ .PHONY: T13340
+ T13340:
+- '$(TEST_HC)' $(TEST_HC_OPTS) -c -O T13340.hs -ddump-simpl -dsuppress-all | grep -c '\+#'
++ '$(TEST_HC)' $(TEST_HC_OPTS) -c -O T13340.hs -ddump-simpl -dsuppress-all | grep -c '+#'
+
+
+ # We expect to see all dictionaries specialized away.