aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/fasthenry-spBuild.patch
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-07-22 14:18:27 +0200
committerFederico Beffa <beffa@fbengineering.ch>2015-08-01 12:29:37 +0200
commit23bae7bb862bf466fbee07f498130f156c342489 (patch)
tree349398bb414503dd16a154bd1939703c6b1fe151 /gnu/packages/patches/fasthenry-spBuild.patch
parent930945015c76083efc0dd140d6bd2cbd3ecc44ad (diff)
downloadguix-23bae7bb862bf466fbee07f498130f156c342489.tar.gz
guix-23bae7bb862bf466fbee07f498130f156c342489.zip
gnu: Add fasthenry.
* gnu/packages/engineering.scm (fasthenry): New variable. * gnu/packages/patches/fasthenry-spAllocate.patch, gnu/packages/patches/fasthenry-spBuild.patch, gnu/packages/patches/fasthenry-spFactor.patch, gnu/packages/patches/fasthenry-spSolve.patch, gnu/packages/patches/fasthenry-spUtils.patch: New files. * gnu-system.am (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/patches/fasthenry-spBuild.patch')
-rw-r--r--gnu/packages/patches/fasthenry-spBuild.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/fasthenry-spBuild.patch b/gnu/packages/patches/fasthenry-spBuild.patch
new file mode 100644
index 0000000000..cf250fdc4d
--- /dev/null
+++ b/gnu/packages/patches/fasthenry-spBuild.patch
@@ -0,0 +1,13 @@
+Add forward declarations.
+
+--- fasthenry-3.0/src/fasthenry/sparse/spBuild.c.orig 2015-07-22 10:13:30.884638176 +0200
++++ fasthenry-3.0/src/fasthenry/sparse/spBuild.c 2015-07-22 13:08:48.862973419 +0200
+@@ -106,6 +106,8 @@
+ #include "spDefs.h"
+
+
++static void Translate( MatrixPtr, int*, int* );
++static ExpandTranslationArrays( MatrixPtr, register int );
+
+
+