aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/expat-CVE-2024-45491.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-19 09:57:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-09-19 09:57:10 +0300
commit610b395424c02274800d85585cb542ad66d9afea (patch)
tree90207e9c3dff4bc79af0d341d644c4bcebc6a5e9 /gnu/packages/patches/expat-CVE-2024-45491.patch
parent1b6ce1796abdf497f61f426d61339318f4f4f23d (diff)
downloadguix-610b395424c02274800d85585cb542ad66d9afea.tar.gz
guix-610b395424c02274800d85585cb542ad66d9afea.zip
gnu: expat: Fix security vulnerabilities.
Fixes CVE-2024-45490, CVE-2024-45491, CVE-2024-45492. * gnu/packages/xml.scm (expat)[replacement]: New field. (expat/fixed): New variable. * gnu/packages/patches/expat-CVE-2024-45490.patch, gnu/packages/patches/expat-CVE-2024-45491.patch, gnu/packages/patches/expat-CVE-2024-45492.patch: New files. * gnu/local.mk (dist_patch_DATA): Register them. Change-Id: I74d5d7bce98d6c983b989c1afec7cf28777d1617
Diffstat (limited to 'gnu/packages/patches/expat-CVE-2024-45491.patch')
-rw-r--r--gnu/packages/patches/expat-CVE-2024-45491.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/patches/expat-CVE-2024-45491.patch b/gnu/packages/patches/expat-CVE-2024-45491.patch
new file mode 100644
index 0000000000..8ff10559bf
--- /dev/null
+++ b/gnu/packages/patches/expat-CVE-2024-45491.patch
@@ -0,0 +1,34 @@
+https://github.com/libexpat/libexpat/commit/8e439a9947e9dc80a395c0c7456545d8d9d9e421.patch
+Fixed in 2.6.3.
+
+From 8e439a9947e9dc80a395c0c7456545d8d9d9e421 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 19 Aug 2024 22:34:13 +0200
+Subject: [PATCH] lib: Detect integer overflow in dtdCopy
+
+Reported by TaiYou
+---
+ expat/lib/xmlparse.c | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/lib/xmlparse.c b/lib/xmlparse.c
+index 91682c188..e2327bdcf 100644
+--- a/lib/xmlparse.c
++++ b/lib/xmlparse.c
+@@ -7016,6 +7016,16 @@ dtdCopy(XML_Parser oldParser, DTD *newDtd, const DTD *oldDtd,
+ if (! newE)
+ return 0;
+ if (oldE->nDefaultAtts) {
++ /* Detect and prevent integer overflow.
++ * The preprocessor guard addresses the "always false" warning
++ * from -Wtype-limits on platforms where
++ * sizeof(int) < sizeof(size_t), e.g. on x86_64. */
++#if UINT_MAX >= SIZE_MAX
++ if ((size_t)oldE->nDefaultAtts
++ > ((size_t)(-1) / sizeof(DEFAULT_ATTRIBUTE))) {
++ return 0;
++ }
++#endif
+ newE->defaultAtts
+ = ms->malloc_fcn(oldE->nDefaultAtts * sizeof(DEFAULT_ATTRIBUTE));
+ if (! newE->defaultAtts) {