aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/emacs-next-exec-path.patch
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-06 17:58:13 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-08 08:40:57 +0200
commit2e0ed79118440a28fe14939dbafbad1e01180451 (patch)
treeaf58288e3dbf6e577b2d4a0e7ef810d6a726c116 /gnu/packages/patches/emacs-next-exec-path.patch
parent6e63530954cf43c92fe0597f6114e3fe629f65cd (diff)
downloadguix-2e0ed79118440a28fe14939dbafbad1e01180451.tar.gz
guix-2e0ed79118440a28fe14939dbafbad1e01180451.zip
gnu: emacs-next-minimal: Apply Guix patches.
* gnu/packages/patches/emacs-next-native-comp-driver-options.patch: Add file. * gnu/packages/patches/emacs-next-exec-path.patch: Add file. * gnu/local.mk (dist_patch_DATA): Register them here. * gnu/packages/emacs.scm (emacs-next-minimal)[origin](patches): Include the same patches as emacs-minimal, save for the variants specific to emacs-next introduced above. Co-Authored-By: Nicolas Graves <ngraves@ngraves.fr> Fixes: ‘emacs-next’ is almost unusable <https://bugs.gnu.org/66227>
Diffstat (limited to 'gnu/packages/patches/emacs-next-exec-path.patch')
-rw-r--r--gnu/packages/patches/emacs-next-exec-path.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/emacs-next-exec-path.patch b/gnu/packages/patches/emacs-next-exec-path.patch
new file mode 100644
index 0000000000..6e33e25258
--- /dev/null
+++ b/gnu/packages/patches/emacs-next-exec-path.patch
@@ -0,0 +1,18 @@
+Do not capture the build-time value of $PATH in the 'emacs' executable
+since this can noticeably increase the size of the closure of Emacs
+with things like GCC being referenced.
+
+Index: emacs-next/lisp/loadup.el
+===================================================================
+--- emacs-next.orig/lisp/loadup.el
++++ emacs-next/lisp/loadup.el
+@@ -599,7 +599,8 @@ lost after dumping")))
+ ((equal dump-mode "dump") "emacs")
+ ((equal dump-mode "bootstrap") "emacs")
+ ((equal dump-mode "pbootstrap") "bootstrap-emacs.pdmp")
+- (t (error "Unrecognized dump mode %s" dump-mode)))))
++ (t (error "Unrecognized dump mode %s" dump-mode))))
++ (exec-path nil))
+ (when (and (featurep 'native-compile)
+ (equal dump-mode "pdump"))
+ ;; Don't enable this before bootstrap is completed, as the