aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-02-24 19:29:14 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-12 23:30:06 +0100
commitb74e5283bbba1370429e4f1a6a7348843aa76f80 (patch)
treecdf74248e34efa2509ce61c4982ac38930498de6 /gnu/packages/password-utils.scm
parentf558e141991e72409baea65351ec8d3ecc8e076b (diff)
downloadguix-b74e5283bbba1370429e4f1a6a7348843aa76f80.tar.gz
guix-b74e5283bbba1370429e4f1a6a7348843aa76f80.zip
gnu: Add hydra.
* gnu/packages/password-utils.scm (hydra): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 9fc41d9b0a..9ea1ce00a5 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -67,6 +68,7 @@
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages aidc)
@@ -103,6 +105,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages rdesktop)
#:use-module (gnu packages readline)
#:use-module (gnu packages ruby)
#:use-module (gnu packages security-token)
@@ -1349,6 +1352,35 @@ function. Since they all work with @code{STDIN} and @code{STDOUT} you can
group them into chains.")
(license license:expat)))
+(define-public hydra
+ (package
+ (name "hydra")
+ (version "9.4")
+ (home-page "https://github.com/vanhauser-thc/thc-hydra")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0dbx7yaqf4nl63pi8wmr19cxnp5v4w7fsd369krdy8hlc8k0qjgr"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no test suite
+ #:make-flags (list (string-append "CC="
+ ,(cc-for-target)))))
+ (native-inputs (list pkg-config))
+ (inputs (list freerdp gtk+ openssl zlib))
+ (synopsis "Gain access to a remote system by trying logins and passwords")
+ (description
+ "This package provides a tool to demonstrate how easy it is to gain
+unauthorized access to a system by automatically attempting logins and
+passwords. It supports a wide range of protocols including SSH, SMTP and
+HTTP.")
+ (license license:agpl3+)))
+
(define-public bruteforce-luks
(package
(name "bruteforce-luks")