aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2024-11-17 16:29:59 +0100
committerEkaitz Zarraga <ekaitz@elenq.tech>2024-12-06 14:27:55 +0100
commit0c5d7b8480234f739448956f508307e64e8e45fa (patch)
tree9ca159ecdaf70340fa0851c45bac5c489958a32a /gnu/packages/password-utils.scm
parentd75d1fe6ac7ded7e61322d18b07d347beb609aa0 (diff)
downloadguix-0c5d7b8480234f739448956f508307e64e8e45fa.tar.gz
guix-0c5d7b8480234f739448956f508307e64e8e45fa.zip
gnu: Update otpclient to 4.0.2
Requires updating `libcotp` to 3.1.0, that introduced a new way for testing that requires `criterium`, a package we don't have and that has dependencies that we don't have either. As the tests in `libcotp` are not an exhaustive testsuite and `otpclient` is its only dependent package, tests are disabled for the moment. * gnu/packages/authentication.scm (libcotp): Update to 3.1.0 [arguments] Disable tests. * gnu/packages/password-utils.scm (otpclient): Update to 4.0.2 Change-Id: Ie6d37b5efe59397d4979c7490b94f1c871c27d6d
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index dcd155835a..2820fa60d0 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -328,7 +328,7 @@ Counterpane's Passwordsafe.")
(define-public otpclient
(package
(name "otpclient")
- (version "3.1.9")
+ (version "4.0.2")
(source
(origin
(method git-fetch)
@@ -337,7 +337,7 @@ Counterpane's Passwordsafe.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0n5h76zwchdp3nbiczcfcg9sr0hbfs1npwq26x78rz8jf6md898m"))))
+ (base32 "061idzh9sz556nm7ahjrvcbnbmgvgfwmph1lfiy7bcvj1g3rf8cm"))))
(build-system cmake-build-system)
(arguments
(list