aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/parallel.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-12 14:00:01 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-19 16:15:05 +0200
commit06e6a161aa21346c5f3cb2dcb76c1f0d989da758 (patch)
tree5bbfd17c75e6b70838db05f78fbdfe7feb6dcf94 /gnu/packages/parallel.scm
parent9aa38f98cbd41644abe2c43bb4f44f74df642df2 (diff)
downloadguix-06e6a161aa21346c5f3cb2dcb76c1f0d989da758.tar.gz
guix-06e6a161aa21346c5f3cb2dcb76c1f0d989da758.zip
gnu: Add openpmix.
* gnu/packages/parallel.scm (openpmix): New variable. Change-Id: Id23bc710c9b61ede0aebf7e2a18863fbe5fb8304 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/parallel.scm')
-rw-r--r--gnu/packages/parallel.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index 2e00701582..1eae4570a1 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
+;;; Copyright © 2024 Romain Garbage <romain.garbage@inria.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -51,6 +52,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
#:use-module (gnu packages freeipmi)
+ #:use-module (gnu packages libevent)
#:use-module (gnu packages linux)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
@@ -612,3 +614,31 @@ debug information.
"This header-only C++ library provides a portable interface to
single-instruction multiple-data (SIMD) intrinsics.")
(license license:expat))))
+
+(define-public openpmix
+ (package
+ (name "openpmix")
+ (version "4.2.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/openpmix/openpmix/releases/download/v"
+ version "/pmix-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1j9xlhqrrmgjdkwakamn78y5gj756adi53hn25zksgr3is3l5d09"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list (string-append "--with-hwloc="
+ (ungexp (this-package-input "hwloc") "lib")))))
+ (inputs (list libevent `(,hwloc "lib")))
+ (native-inputs (list perl python))
+ (synopsis "PMIx library")
+ (description
+ "PMIx is an application programming interface standard that provides
+libraries and programming models with portable and well-defined access to
+commonly needed services in distributed and parallel computing systems.")
+ (home-page "https://pmix.org/")
+ ;; The provided license is kind of BSD-style but specific.
+ (license (license:fsf-free "https://github.com/openpmix/openpmix?tab=License-1-ov-file#License-1-ov-file"))))