aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/pantheon.scm
diff options
context:
space:
mode:
authoraltadil <Altadil@protonmail.com>2024-08-30 09:40:23 +0000
committerjgart <jgart@dismail.de>2024-09-03 06:55:47 -0500
commit8f584d2bdb0a5a5e78f04ce0b468d99605157420 (patch)
treeaf702f6e2b0769f623e6442096ad2a680234968d /gnu/packages/pantheon.scm
parent959e74bd72dc961754f9417a8141a2db42404f6c (diff)
downloadguix-8f584d2bdb0a5a5e78f04ce0b468d99605157420.tar.gz
guix-8f584d2bdb0a5a5e78f04ce0b468d99605157420.zip
gnu: Add pantheon-stylesheet.
* gnu/packages/pantheon.scm (pantheon-stylesheet): New variable. Change-Id: I33b8d144198e8ef51631ed3050a2f9e3fb25c3a4 Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/pantheon.scm')
-rw-r--r--gnu/packages/pantheon.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index eaaf70c624..3c551d778b 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -198,6 +198,28 @@ also be used on others.")
(home-page "https://elementary.io/open-source")
(license license:lgpl2.1+)))
+(define-public pantheon-stylesheet
+ (package
+ (name "pantheon-stylesheet")
+ (version "8.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/stylesheet")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h8k75m9jrqxwq0py8hrqrsc83myrwpmnrwx05aljdyr6sys06k6"))))
+ (build-system meson-build-system)
+ (native-inputs (list gettext-minimal)) ;for msgfmt
+ (inputs (list sassc))
+ (synopsis "GTK stylesheet for the Pantheon desktop")
+ (description "pantheon-stylesheet is the GTK Stylesheet for the Pantheon
+desktop environment (originally from elementary OS).")
+ (home-page "https://elementary.io/open-source")
+ (license license:gpl3+)))
+
(define-public pantheon-terminal
(package
(name "pantheon-terminal")