aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-11 08:33:02 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:41 +0000
commitfdc0fefd46a45b70784a4e3f8900cbe593426a9e (patch)
tree13c3736334bde1c3ec75d67f4e430396e23eed3f /gnu/packages/package-management.scm
parentca945f7c35bbc5d05a6ad7e5baa15f79e0fd0ecc (diff)
downloadguix-fdc0fefd46a45b70784a4e3f8900cbe593426a9e.tar.gz
guix-fdc0fefd46a45b70784a4e3f8900cbe593426a9e.zip
build-system/pyproject: Use python-sans-pip-wrapper as default-python.
Also adds python-setuptools and python-wheel to relevant packages, either to native-inputs or to propagated inputs if the pkg_resources Python module is loaded at runtime. * guix/build-system/pyproject.scm (default-python): Default to python-sans-pip-wrapper. Change-Id: I2d986c2225114f54459dd6bb360913106e52cdf4
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 8b4c408874..97c0bb675d 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1090,7 +1090,11 @@ and not test_conda_root_outside_root_environment"))
(add-before 'check 'set-HOME
(lambda _ (setenv "HOME" "/tmp"))))))
(propagated-inputs
- (list python-clyent python-nbformat python-pyyaml python-requests))
+ (list python-clyent
+ python-nbformat
+ python-pyyaml
+ python-requests
+ python-setuptools))
(native-inputs
(list python-coverage
python-dateutil
@@ -1098,7 +1102,8 @@ and not test_conda_root_outside_root_environment"))
python-mock
python-pillow
python-pytest
- python-pytz))
+ python-pytz
+ python-wheel))
(home-page "https://github.com/Anaconda-Platform/anaconda-client")
(synopsis "Anaconda Cloud command line client library")
(description