aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-01 22:21:09 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-01 22:21:09 +0200
commit8de4131b2ddd11faa3394cf497484563068c9e7a (patch)
treeed4ed9e586c7236f09c109afdd416dac18ba8cc3 /gnu/packages/package-management.scm
parent15406013fe63f2ab238eec2d7a8adbc586806ac8 (diff)
parent45b7a8bfda5bde2e2daee4bec0ca092cd719d726 (diff)
downloadguix-8de4131b2ddd11faa3394cf497484563068c9e7a.tar.gz
guix-8de4131b2ddd11faa3394cf497484563068c9e7a.zip
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm244
1 files changed, 121 insertions, 123 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 9312d34242..dacd4433d2 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1169,17 +1169,16 @@ written entirely in Python.")
(define-public conan
(package
(name "conan")
- (version "2.0.2")
+ (version "2.0.9")
(source
(origin
- (method git-fetch) ;no tests in PyPI archive
+ (method git-fetch) ; no tests in PyPI archive
(uri (git-reference
(url "https://github.com/conan-io/conan")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32
- "1y4qmqnw3s8xv64lgp388qpj9vqharyfqi5s8dxvgsns6cafv7lf"))))
+ (base32 "1ykfj7c3i0b57s7ql3p2lawxdzd2cn36f3k8p64lyzla8rwv4xdx"))))
(build-system python-build-system)
(arguments
(list
@@ -1299,7 +1298,7 @@ tools_locations = {
python-pluginbase
python-pygments
python-pyjwt
- python-pyyaml-5
+ python-pyyaml
python-requests
python-six
python-tqdm
@@ -1409,8 +1408,8 @@ environments.")
"0k9zkdyyzir3fvlbcfcqy17k28b51i20rpbjwlx2i1mwd2pw9cxc")))))))
(define-public guix-build-coordinator
- (let ((commit "c44d485bba42034804beb47afc23005c4e73ea96")
- (revision "85"))
+ (let ((commit "f39f16000469429745bd8aff3cd4d59b7c489fa1")
+ (revision "86"))
(package
(name "guix-build-coordinator")
(version (git-version "0" revision commit))
@@ -1421,75 +1420,74 @@ environments.")
(commit commit)))
(sha256
(base32
- "1y69yrmmifdp55l5c5b8iiq0llwpggxmq6a4233cdll3bhfxaicl"))
+ "1lmbwbza87xzbvmzw44sgpscmqjfl5kpgfl79n7hzwa1icqqb7mg"))
(file-name (string-append name "-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
- `(#:modules (((guix build guile-build-system)
+ (list
+ #:modules `(((guix build guile-build-system)
#:select (target-guile-effective-version))
,@%gnu-build-system-modules)
- #:imported-modules ((guix build guile-build-system)
+ #:imported-modules `((guix build guile-build-system)
,@%gnu-build-system-modules)
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'set-GUILE_AUTO_COMPILE
- (lambda _
- ;; To avoid warnings relating to 'guild'.
- (setenv "GUILE_AUTO_COMPILE" "0")
- #t))
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs target #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (guile (assoc-ref inputs "guile"))
- (version (target-guile-effective-version))
- (scm (string-append out "/share/guile/site/" version))
- (go (string-append out "/lib/guile/" version "/site-ccache")))
- (for-each
- (lambda (file)
- (simple-format (current-error-port) "wrapping: ~A\n" file)
- (let ((guile-inputs (list
- "guile-json"
- "guile-gcrypt"
- "guix"
- "guile-prometheus"
- "guile-lib"
- "guile-lzlib"
- "guile-zlib"
- "guile-sqlite3"
- "guile-gnutls"
- ,@(if (target-hurd?)
- '()
- '("guile-fibers")))))
- (wrap-program file
- `("PATH" ":" prefix
- (,bin
- ;; Support building without sqitch as an input, as it
- ;; can't be cross-compiled yet
- ,@(or (and=> (assoc-ref inputs "sqitch")
- list)
- '())))
- `("GUILE_LOAD_PATH" ":" prefix
- (,scm ,(string-join
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'set-GUILE_AUTO_COMPILE
+ (lambda _
+ ;; To avoid warnings relating to 'guild'.
+ (setenv "GUILE_AUTO_COMPILE" "0")))
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs target #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (guile (assoc-ref inputs "guile"))
+ (version (target-guile-effective-version))
+ (scm (string-append out "/share/guile/site/" version))
+ (go (string-append out "/lib/guile/" version "/site-ccache")))
+ (for-each
+ (lambda (file)
+ (simple-format (current-error-port) "wrapping: ~A\n" file)
+ (let ((guile-inputs (list
+ "guile-json"
+ "guile-gcrypt"
+ "guix"
+ "guile-prometheus"
+ "guile-lib"
+ "guile-lzlib"
+ "guile-zlib"
+ "guile-sqlite3"
+ "guile-gnutls"
+ #$@(if (target-hurd?)
+ '()
+ '("guile-fibers")))))
+ (wrap-program file
+ `("PATH" ":" prefix
+ (,bin
+ ;; Support building without sqitch as an input, as it
+ ;; can't be cross-compiled yet
+ ,@(or (and=> (assoc-ref inputs "sqitch")
+ list)
+ '())))
+ `("GUILE_LOAD_PATH" ":" prefix
+ (,scm ,(string-join
+ (map (lambda (input)
+ (simple-format
+ #f "~A/share/guile/site/~A"
+ (assoc-ref inputs input)
+ version))
+ guile-inputs)
+ ":")))
+ `("GUILE_LOAD_COMPILED_PATH" ":" prefix
+ (,go ,(string-join
(map (lambda (input)
(simple-format
- #f "~A/share/guile/site/~A"
+ #f "~A/lib/guile/~A/site-ccache"
(assoc-ref inputs input)
version))
guile-inputs)
- ":")))
- `("GUILE_LOAD_COMPILED_PATH" ":" prefix
- (,go ,(string-join
- (map (lambda (input)
- (simple-format
- #f "~A/lib/guile/~A/site-ccache"
- (assoc-ref inputs input)
- version))
- guile-inputs)
- ":"))))))
- (find-files bin)))
- #t))
- (delete 'strip)))) ; As the .go files aren't compatible
+ ":"))))))
+ (find-files bin)))))
+ (delete 'strip)))) ; As the .go files aren't compatible
(native-inputs
(list pkg-config
autoconf
@@ -1654,8 +1652,8 @@ in an isolated environment, in separate namespaces.")
(license license:gpl3+)))
(define-public nar-herder
- (let ((commit "b27ca4dc0efbb0d9c397fc39347af9b8e8734ab9")
- (revision "20"))
+ (let ((commit "53682fac7e00cd2801406edbd014922c1720c347")
+ (revision "21"))
(package
(name "nar-herder")
(version (git-version "0" revision commit))
@@ -1666,64 +1664,64 @@ in an isolated environment, in separate namespaces.")
(commit commit)))
(sha256
(base32
- "075acihpxvw4rkmbn7wiswqixv2afla8d8x7mgxqc26hba090404"))
+ "18mzrpc5ni8d6xbp1bg0nzdj0brmnji4jm1gyiq77dm17c118zyz"))
(file-name (string-append name "-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
- `(#:modules (((guix build guile-build-system)
+ (list
+ #:modules `(((guix build guile-build-system)
#:select (target-guile-effective-version))
,@%gnu-build-system-modules)
- #:imported-modules ((guix build guile-build-system)
+ #:imported-modules `((guix build guile-build-system)
,@%gnu-build-system-modules)
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'set-GUILE_AUTO_COMPILE
- (lambda _
- ;; To avoid warnings relating to 'guild'.
- (setenv "GUILE_AUTO_COMPILE" "0")))
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs target #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (guile (assoc-ref inputs "guile"))
- (version (target-guile-effective-version))
- (scm (string-append out "/share/guile/site/" version))
- (go (string-append out "/lib/guile/" version "/site-ccache")))
- (for-each
- (lambda (file)
- (simple-format (current-error-port) "wrapping: ~A\n" file)
- (let ((guile-inputs (list
- "guile-json"
- "guile-gcrypt"
- "guix"
- "guile-lib"
- "guile-lzlib"
- "guile-zstd"
- "guile-prometheus"
- "guile-sqlite3"
- "guile-gnutls"
- "guile-fibers")))
- (wrap-program file
- `("GUILE_LOAD_PATH" ":" prefix
- (,scm ,(string-join
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'set-GUILE_AUTO_COMPILE
+ (lambda _
+ ;; To avoid warnings relating to 'guild'.
+ (setenv "GUILE_AUTO_COMPILE" "0")))
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs target #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (guile (assoc-ref inputs "guile"))
+ (version (target-guile-effective-version))
+ (scm (string-append out "/share/guile/site/" version))
+ (go (string-append out "/lib/guile/" version "/site-ccache")))
+ (for-each
+ (lambda (file)
+ (simple-format (current-error-port) "wrapping: ~A\n" file)
+ (let ((guile-inputs (list
+ "guile-json"
+ "guile-gcrypt"
+ "guix"
+ "guile-lib"
+ "guile-lzlib"
+ "guile-zstd"
+ "guile-prometheus"
+ "guile-sqlite3"
+ "guile-gnutls"
+ "guile-fibers")))
+ (wrap-program file
+ `("GUILE_LOAD_PATH" ":" prefix
+ (,scm ,(string-join
+ (map (lambda (input)
+ (string-append
+ (assoc-ref inputs input)
+ "/share/guile/site/"
+ version))
+ guile-inputs)
+ ":")))
+ `("GUILE_LOAD_COMPILED_PATH" ":" prefix
+ (,go ,(string-join
(map (lambda (input)
(string-append
(assoc-ref inputs input)
- "/share/guile/site/"
- version))
+ "/lib/guile/" version "/site-ccache"))
guile-inputs)
- ":")))
- `("GUILE_LOAD_COMPILED_PATH" ":" prefix
- (,go ,(string-join
- (map (lambda (input)
- (string-append
- (assoc-ref inputs input)
- "/lib/guile/" version "/site-ccache"))
- guile-inputs)
- ":"))))))
- (find-files bin)))
- #t))
- (delete 'strip)))) ; As the .go files aren't compatible
+ ":"))))))
+ (find-files bin)))))
+ (delete 'strip)))) ; As the .go files aren't compatible
(native-inputs
(list pkg-config
autoconf
@@ -1772,20 +1770,20 @@ and the error handling is very rough.")
(define-public gcab
(package
(name "gcab")
- (version "1.4")
+ (version "1.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/gcab/"
version "/gcab-" version ".tar.xz"))
(sha256
(base32
- "13q43iqld4l50yra45lhvkd376pn6qpk7rkx374zn8y9wsdzm9b7"))))
+ "02sngv40zwadajsiav1paahyfgkccbh9s7r5ks82chbwawarc31g"))))
(build-system meson-build-system)
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-mkenums
- ("intltool" ,intltool)
- ("pkg-config" ,pkg-config)
- ("vala" ,vala)))
+ (list `(,glib "bin") ; for glib-mkenums
+ intltool
+ pkg-config
+ vala))
(inputs
(list glib zlib))
(arguments
@@ -1865,7 +1863,7 @@ for packaging and deployment of cross-compiled Windows applications.")
docbook-xml
docbook-xsl
e2fsprogs
- fuse
+ fuse-2
glib
gpgme
libarchive
@@ -1966,7 +1964,7 @@ cp -r /tmp/locale/*/en_US.*")))
bubblewrap
curl
dconf
- fuse
+ fuse-2
gdk-pixbuf
gpgme
json-glib