aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:16 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:57 +0000
commitc91f8f9b7b2160e514d985faf94aeceac8feb25f (patch)
tree2769783a813e8a1990e4c0691f07a3e85f37ec47 /gnu/packages/ocaml.scm
parent3f84fbd2f17b3907f35492ab93765c8ad2760801 (diff)
downloadguix-c91f8f9b7b2160e514d985faf94aeceac8feb25f.tar.gz
guix-c91f8f9b7b2160e514d985faf94aeceac8feb25f.zip
gnu: Add ocaml-textutils-kernel.
* gnu/packages/ocaml.scm (ocaml-textutils-kernel): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4333782f86..890fdfda9c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8439,6 +8439,29 @@ or select, depending on availability, and manages a thread pool that blocking
system calls run in.")
(license license:expat)))
+(define-public ocaml-textutils-kernel
+ (package
+ (name "ocaml-textutils-kernel")
+ (version "0.15.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/textutils_kernel")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "068g11d98wsb5a6ds0p5xybdmx5nx9bxa0k11dmh3l57kn4c169x"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-core ocaml-ppx-jane ocaml-uutf))
+ (properties `((upstream-name . "textutils_kernel")))
+ (home-page "https://github.com/janestreet/textutils_kernel")
+ (synopsis "Text output utilities")
+ (description
+ "The subset of textutils using only core_kernel and working in
+javascript.")
+ (license license:expat)))
+
(define-public ocaml-timezone
(package
(name "ocaml-timezone")