aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:26 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:58 +0000
commit9658d29ab875e4c0ab60ba8399b5d237e5a2ff9f (patch)
tree4901f7fa92c06c5e77e87bf77d9eae8aea7a1934 /gnu/packages/ocaml.scm
parent991a289a023c1f466564c5a878f98d7f3ae6a8b9 (diff)
downloadguix-9658d29ab875e4c0ab60ba8399b5d237e5a2ff9f.tar.gz
guix-9658d29ab875e4c0ab60ba8399b5d237e5a2ff9f.zip
gnu: Add ocaml-mirage-xen.
* gnu/packages/ocaml.scm (ocaml-mirage-xen): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a1f691c655..2219ec72c0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3084,6 +3084,40 @@ The client and the server libraries have sets of unit-tests.")
;; Has a linking exception, see LICENSE.md.
(license license:lgpl2.1)))
+(define-public ocaml-mirage-xen
+ (package
+ (name "ocaml-mirage-xen")
+ (version "8.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mirage/mirage-xen")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qydg92dbw8hj4b809apj0f51cjgmamq3zdf34a4wyn5jv85yzyx"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-cstruct
+ ocaml-lwt
+ ocaml-shared-memory-ring-lwt
+ ocaml-xenstore
+ ocaml-lwt-dllist
+ ;; ocaml-mirage-profile dependency cycle
+ ocaml-io-page
+ ocaml-mirage-runtime
+ ocaml-logs
+ ocaml-fmt
+ ocaml-bheap
+ ocaml-duration))
+ (home-page "https://github.com/mirage/mirage-xen")
+ (synopsis "Xen core platform libraries for MirageOS")
+ (description
+ "MirageOS OS library for Xen targets, which handles the main
+loop and timers. It also provides the low level C startup code and C stubs
+required by the OCaml code.")
+ (license license:isc)))
+
(define-public ocaml-io-page
(package
(name "ocaml-io-page")