aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-12-16 13:25:04 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-12-21 21:59:11 +0100
commit642cf11aa2715b939ed450ccddc00860b22b709e (patch)
treec38a3c2ad6709a3d29660a6bce39a757a2be4794 /gnu/packages/ocaml.scm
parent052ec8bcc73d1c37e20a8eba85b4431bcff5447c (diff)
downloadguix-642cf11aa2715b939ed450ccddc00860b22b709e.tar.gz
guix-642cf11aa2715b939ed450ccddc00860b22b709e.zip
gnu: opam: Use OCaml 4.14 compiled version when building OCaml 5.0 packages.
* gnu/packages/ocaml.scm (opam)[properties]: Add ocaml5.0-variant. (opam)[propagated-inputs]: Move to inputs. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index adbb76711e..f32d7b4f22 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -962,10 +962,12 @@ name = Guix Builder")
("opam-repo-f372039d" ,(opam-repo "f372039db86a970ef3e662adbfe0d4f5cd980701"
"0ld7fcry6ss6fmrpswvr6bikgx299w97h0gwrjjh7kd7rydsjdws")))))
(inputs
- (list ocaml ncurses curl bubblewrap))
- (propagated-inputs
- (list ocaml-cmdliner ocaml-dose3 ocaml-mccs ocaml-opam-file-format
- ocaml-re))
+ (list ocaml ncurses curl bubblewrap ocaml-cmdliner ocaml-dose3
+ ocaml-mccs ocaml-opam-file-format ocaml-re))
+ (properties
+ ;; OPAM is used as a tool and not as a library, we can use the OCaml 4.14
+ ;; compiled opam until opam is compatible with OCaml 5.0.
+ `((ocaml5.0-variant . ,(delay opam))))
(home-page "http://opam.ocamlpro.com/")
(synopsis "Package manager for OCaml")
(description