aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2024-01-10 08:43:17 +0100
committerJulien Lepiller <julien@lepiller.eu>2024-02-08 23:16:37 +0100
commit48145430c3a7aed121365e7706f1329b667bf675 (patch)
tree2b25bf4897d1c536e6ef74470d9abc86ff23e6ea /gnu/packages/ocaml.scm
parent45e68894555f762bb4373cd50985b91d2d8fc937 (diff)
downloadguix-48145430c3a7aed121365e7706f1329b667bf675.tar.gz
guix-48145430c3a7aed121365e7706f1329b667bf675.zip
gnu: ocaml-bin-prot: Update to 0.16.0.
* gnu/packages/ocaml.scm (ocam-bin-prot): Update to 0.16.0. (bap)[arguments]: Fix code after ocaml-bin-prot changes. Change-Id: I0756cfaaed2e487c18f6cab119fb7ac8b2863edd
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index dfbe391271..6306490a3b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5037,6 +5037,11 @@ necessary set of rewriters.")
;; We don't have a monolithic llvm
(substitute* "oasis/llvm.setup.ml.in"
(("llvm_static = \"true\"") "true"))
+ ;; Package update removed Make_binable, which was an alias
+ ;; for Make_binable_without_uuid
+ (substitute* (find-files "." ".")
+ (("Utils.Make_binable1\\(") "Utils.Make_binable1_without_uuid(")
+ (("Utils.Make_binable\\(") "Utils.Make_binable_without_uuid("))
(invoke "./configure" "--prefix"
(assoc-ref outputs "out")
"--libdir"
@@ -6495,7 +6500,7 @@ different versions of the code to safely communicate.")
(define-public ocaml-bin-prot
(package
(name "ocaml-bin-prot")
- (version "0.15.0")
+ (version "0.16.0")
(source
(origin
(method git-fetch)
@@ -6504,7 +6509,7 @@ different versions of the code to safely communicate.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1qfqglscc25wwnjx7byqmjcnjww1msnr8940gyg8h93wdq43fjnh"))))
+ (base32 "1ybs0152ilgr8sa1hqnc2jj0gbvg855ixl3c5b2pjbnk7blhqnd8"))))
(build-system dune-build-system)
(propagated-inputs
(list ocaml-base
@@ -6513,6 +6518,7 @@ different versions of the code to safely communicate.")
ocaml-ppx-fields-conv
ocaml-ppx-optcomp
ocaml-ppx-sexp-conv
+ ocaml-ppx-stable-witness
ocaml-ppx-variants-conv))
(properties `((upstream-name . "bin_prot")))
(home-page "https://github.com/janestreet/bin_prot")