aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:07 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:55 +0000
commit0d4ff1c2ad9b1451e38ede6f647eae492125cc08 (patch)
treeffb4f510006d99a9539c14e884a55cf4c69606aa /gnu/packages/ocaml.scm
parentfa0c8e82608d51aadd9436e0351d2415924921bb (diff)
downloadguix-0d4ff1c2ad9b1451e38ede6f647eae492125cc08.tar.gz
guix-0d4ff1c2ad9b1451e38ede6f647eae492125cc08.zip
gnu: Add ocaml-mirage-clock.
* gnu/packages/ocaml.scm (ocaml-mirage-clock): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 061654facd..3c77cbfa9b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3825,6 +3825,30 @@ provided check the input and raise on negative or out of bound input.")
"Defines the signature for time-related operations for MirageOS.")
(license license:isc)))
+(define-public ocaml-mirage-clock
+ (package
+ (name "ocaml-mirage-clock")
+ (version "4.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mirage/mirage-clock")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rkara9i3dvnzrb8jl2vkx8hgamvxnksin67wmhbv9d4i758amjy"))))
+ (build-system dune-build-system)
+ (home-page "https://github.com/mirage/mirage-clock")
+ (synopsis "Libraries and module types for portable clocks")
+ (description
+ "This library implements portable support for an operating system
+timesource that is compatible with the MirageOS library interfaces. It
+implements an @code{MCLOCK} module that represents a monotonic timesource
+since an arbitrary point, and @code{PCLOCK} which counts time since the Unix
+epoch.")
+ (license license:isc)))
+
(define-public ocaml-mirage-unix
(package
(name "ocaml-mirage-unix")