aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/nicotine.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-17 22:24:02 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-30 21:36:12 +0100
commitf9bb983d3ecbbf256f8ec785f837ad9cd4a00361 (patch)
treecd48122a2ce46d78723dddf52452c822ed58e015 /gnu/packages/nicotine.scm
parent48895affab469b7a8df18b247b97ec9816d8d30a (diff)
downloadguix-f9bb983d3ecbbf256f8ec785f837ad9cd4a00361.tar.gz
guix-f9bb983d3ecbbf256f8ec785f837ad9cd4a00361.zip
gnu: python-regions: Update to 0.9.
* gnu/packages/astronomy.scm (python-regions): Update to 0.9. [arguments] <#:phases>: Add 'create-setup.py phase, rename 'prepare-test-environment to 'build-extensions to reflect purpose. [native-inputs]: Remove python-cython; add python-cython-3. Change-Id: Ia634f93336eb7658c4eaeeb7ddb6539c2e0adee3
Diffstat (limited to 'gnu/packages/nicotine.scm')
0 files changed, 0 insertions, 0 deletions
hes/jsoncpp-pkg-config-version.patch?id=1d221b7fea1985a02e6b5d2f23894f663acfadd3'>gnu/packages/patches/jsoncpp-pkg-config-version.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Taken from upstream: https://github.com/open-source-parsers/jsoncpp/issues/1235.
-
-From ac2870298ed5b5a96a688d9df07461b31f83e906 Mon Sep 17 00:00:00 2001
-From: Derick Vigne <derickvigne@me.com>
-Date: Tue, 26 Jan 2021 14:59:12 -0500
-Subject: [PATCH] Fixed pkg-config Version
-
----
- pkg-config/jsoncpp.pc.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/pkg-config/jsoncpp.pc.in b/pkg-config/jsoncpp.pc.in
-index 632a377f5..2a2221069 100644
---- a/pkg-config/jsoncpp.pc.in
-+++ b/pkg-config/jsoncpp.pc.in
-@@ -5,7 +5,7 @@ includedir=@includedir_for_pc_file@
-
- Name: jsoncpp
- Description: A C++ library for interacting with JSON
--Version: @JSONCPP_VERSION@
-+Version: @PROJECT_VERSION@
- URL: https://github.com/open-source-parsers/jsoncpp
- Libs: -L${libdir} -ljsoncpp
- Cflags: -I${includedir}
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index cec9b68299..960c339ef9 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -414,17 +414,15 @@ in which the loaded data is arranged in memory.")
(define-public jsoncpp
(package
(name "jsoncpp")
- (version "1.9.4")
+ (version "1.9.5")
(home-page "https://github.com/open-source-parsers/jsoncpp")
(source (origin
(method git-fetch)
(uri (git-reference (url home-page) (commit version)))
(file-name (git-file-name name version))
- (patches
- (search-patches "jsoncpp-pkg-config-version.patch"))
(sha256
(base32
- "0qnx5y6c90fphl9mj9d20j2dfgy6s5yr5l0xnzid0vh71zrp6jwv"))))
+ "06zss7z56ykzwcsfdxarmini63hkf8i8gx70q3yw9wb0bw7wj9rv"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBUILD_SHARED_LIBS:BOOL=YES"